Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a weird problem with my Firefox 27.0.1: Literally any webpage I want to visit is automatically requested via HTTPS, and that means I constantly get "Untrusted Connection" warnings - see first image below.

I am forced to either give up or accept a certificate exception for the site (see second image below). As a workaround, I can add an exception manually but this gets tedious real quick, because it needs to be done for every site I visit.

What is causing this annoying behavior, if it's not the HTTPS Everywhere plugin?

I had the HTTPS Everywhere plugin installed and I disabled that - it didn't solve the problem so I uninstalled it instead. That still has not solved the problem. Could it be something about the corporate firewall that has been changed?

enter image description here

 
enter image description here

share|improve this question
1  
Did you disable it or uninstall it? Does the same issue occur in IE or in FireFox when in safe mode? –  Dave Mar 4 at 9:14
    
I only disabled it, and even rebooted. I've now really uninstalled it and restarted Firefox - and the problem is gone. ("WTF?") –  Torben Gundtofte-Bruun Mar 4 at 9:22
    
After uninstalling HTTPS-everywhere the problem seemed to be gone, but it's not. Something else is causing this problem. –  Torben Gundtofte-Bruun Mar 11 at 7:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.