Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here is my setup:

  • Everything in running on a single machine, under Mac OS X Snow Leopard.
  • I am running Windows 7 in VirtualBox 3.0.10.
  • In the VirtualBox settings, under Display, Remote Display, I checked "Enable server", and kept the default port (3389). Under Network, I use the Bridge Adapter, so the VirtualBox gets an IP using DHCP, just like OS X does.
  • After starting Windows in VirtualBox, I run ipconfig and see that the IP is 192.168.0.181.
  • From the OS X command line, I can successfully ping 192.168.0.181.

With this setup, I would expect to be able to start Remote Desktop and connect to 192.168.0.181. unfortunately it doesn't work and after about 10 seconds Remote Desktop tells me it can't connect to 192.168.0.181.

Any hit of why this wouldn't work?

share|improve this question
add comment

4 Answers

I was having the exact same problem until I installed the Extension Pack. Turns out the VRDP extension isn't installed by default even though the docs make it sound like it is.

Reading the log file for the VM showed

00:00:00.230 VRDE: VirtualBox Remote Desktop Extension is not available.

share|improve this answer
add comment
up vote 3 down vote accepted

Don't connect to the IP assigned to Windows running inside VirtualBox, but to the host, or simply localhost if connecting from the same machine. This way it works like a charm.

share|improve this answer
add comment

As far as I know, I just re-tested it. Remember also that the account you will connect to must have a password.

You have to enable it also inside Windows 7 as follow (from W7 help) :

How do I allow remote connections on the computer I want to connect to?

If the computer you want to connect to is using Windows 7 Professional, 
Windows 7 Ultimate, or Windows 7 Enterprise, follow these steps:

Click to open System. 

In the left pane, click Remote settings.  If you are prompted for an administrator 
password or confirmation, type the password or provide confirmation. 

In the System Properties dialog box, under Remote Desktop, select one of the 
three options, and then click Select Users. 

If you are an administrator on the computer, your current user account will 
automatically be added to the list of remote users and you can skip the next two steps.

In the Remote Desktop Users dialog box, click Add.

In the Select Users or Groups dialog box, do the following:

To specify the search location, click Locations, and then select the 
location you want to search.

In Enter the object names to select, type the name of the user that you 
want to add, and then click OK. 

The name will be displayed in the list of users in the Remote Desktop 
Users dialog box.
share|improve this answer
    
Yes, this is one way to do it: let Windows handle the Remote Desktop connections. But with VirtualBox, VirtualBox itself handles the Remote Desktop connections, and this is why you should connect to the IP of the host, not the one of Windows (see my response on this). –  avernet Nov 20 '09 at 0:43
    
Windows still needs to be configured to accept RDP connections, regardless of where the connection is handled. –  Joe Internet Nov 20 '09 at 5:51
add comment

Check if windows has firewall enabled, disable it will allow remote connection. With bridged network setting, you have to connect to the IP of guest, not the host.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.