Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My MX 518 Optical mouse's thumb buttons aren't working. I'm running Ubuntu Jaunty Jackalope (64-bit) on VMware. I tried installing HID point and it cannot detect the mouse at all. I'm just wondering if anyone has any idea how I can solve this problem. Thanks.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Try the btnx program (homepage is at http://www.ollisalonen.com/btnx/, and you can install it by running Synaptic or just typing sudo aptitude install btnx). It allows remapping of any mouse buttons, executing some commands when buttons are pressed and more.

Also there may come some problems with the VMware itself because virtualizators do not 'forward' button presses to guest OS (Ubuntu in your case) as themselves but emulate other, commonly PS/2 (but I don't know what exactly WMware does, through emulated USB mouse would not differ much in this context) mice and often drop extended keys when mapping host keypresses to guest keypresses.

You can test this by doing cat /proc/bus/input/devices in console, then searching an entry that describes 'real' mice (I mean not some ACPI stuff or such). Then you need to find a line like H: Handlers=mouseX eventY and do sudo hd /dev/input/eventY. If you are right with your choice then moving your mice will result in some hex being written to console. Then you can test your extended buttons: if you press them and some lines also appear then kernel receives your keypresses and problem is in userspace (software); otherwise it's virtualizer not forwarding such keypresses.

Anyway, btnx should work if you install Ubuntu not as a guest but as a host OS.

share|improve this answer
    
As of today the linked page is dead and btnx doesn't seem to be available on 12.04. –  David Pope May 10 '12 at 5:36
    
@DavidPope btnx package is still in Ubuntu, and the homepage is still available on Wayback Machine. You can also try easystroke, as btnx author recommends it. –  whitequark May 11 '12 at 16:47
add comment

Thumb buttons? What do you mean? Left two? Those won't work. Maybe you can enable them by installing VMware tools and enable the buttons by xorg.conf. Never tried this method, but in theory, its possible. For solution, you can Google around. Since 9.04 is outdate, I just can't really try it anymore. You can use a solution like the following (post #2): http://www.linuxforums.org/forum/peripherals-hardware/43542-5-button-mouse.html . Well, keywords are : 5 button mouse linux (maybe + vmware) ^^"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.