Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed a Cannon wireless printer for temporary use, the drivers of which set nearly all my COM ports to be constantly in-use (an occasionnal bug noted in the ReadMe after installation with no fixes - thanks Canon idiots!).

I have now deleted the printer and drivers but the ports (COM 1-2,4-13 & 15-32) constantly show up as (in-use). Note that they don't appear like this directly in device manager, but do if I try to re-assign a COM port on some hardware (Device Manager -> Port Settings -> Advanced).

I have tried deleting the ports in Control panel -> Print Server Properties but I get the error message 'Selected ports cannot be deleted. The request is not supported'.

I have also tried to delete the ports through Print Management, but here I get the error 'The selected port cannot be deleted. This operation is not supported.'. If I try to configure the ports I get the error 'The selected port cannot be configured. Operated could not be completed (error 0x00000057).

Does anyone have any alternative methods of getting rid of the in-use status from these ports? I work often with embedded hardware connected over USB so need my COM ports free.

share|improve this question

5 Answers 5

Have you tried using an Admin command prompt?

net use com1 /delete

share|improve this answer
    
Thanks for the fast response. I get 'system error 67 has occured'. I'm looking into it now. –  Ad_S Mar 4 at 23:03
    
It looks like it is trying to connect to the printer I uninstalled (according to this article public.madeinengland.co.nz/…;. Do you think I should re-install the printer and then try to delete the COM ports? –  Ad_S Mar 4 at 23:42
    
You could release all of your com ports like this. –  Giggly Gene Mar 5 at 0:10
    
Thanks, I tried that but the ports still show up as in use. I do seem to be able to uninstall the ports from the Device Manager though. –  Ad_S Mar 5 at 17:25

This is a long shot, but I had success with this before on another brand of printer (HP) with hopeless drivers...

Go into device manager
In the menu enable "Show hidden devices"
Then look for Canon devices and disable them.
(Often such fake ghost com-ports are generated by a fake device-driver.)
This just might free those com-ports. (Reboot might be required.)

share|improve this answer
    
Hey Thanks, but there weren't any Canon devices shown. –  Ad_S Mar 4 at 23:20

Try this:

First stop the "Print Spooler" service.
Then go into Regedit and find the key HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Monitors
If there is a sub-key with Canon in the name delete it. That should get rid of the Canon printer-ports altogether.
There could also be Canon stuff under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Providers. If so, get rid of that as well.

Don't forget to restart the Print Spooler service.

share|improve this answer
    
Thanks for the suggestion. I tried that and re-started a few times. It seems that I can now delete the ports from the Device Manager, but they still show up in Devices and Printers -> Print Server Properties -> Ports and do not allow me to re-configure them there They also still show up as in-use on Device Manager -> Ports -> Advanced, though now I have 256 COM ports!!! The new additions are not in-use. –  Ad_S Mar 5 at 0:17

I am assuming that you don't need the Canon drivers any more as you said it was for temporary use. If so, I believe that System Restore will help you.

On Win7, Go to Control Panel - System and Security - System, open "system protection", click "System Restore" button, select "Choose a different restore point" and check "Show more restore points". If you can find a restore point made before installing the drivers, the system will be recovered successfully and your hardware configuration will be just like you didn't install the drivers.

This activity doesn't affect on your personal files as per this FAQ.

share|improve this answer
    
Hi Scott, that was the first thing I tried, but unfortunately the last restore point was a few days after I installed the Canon. –  Ad_S Mar 5 at 14:35

What I ultimately did to clear the offending ports was to assign the port number of COM1 (the one real physical COM port) to each of the offending port numbers, accept the warning that it was in use, and then, after having assigned it each of the in-use numbers, returned it to COM1. After that, all COM ports were available.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.