Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new windows 7 computer. The first thing I did was in stall a 2nd hard drive and mount it at C:/Users/me this seems to work just fine, except one issue.

Search does not find and file there, and the indexing service will not index it.

I think the latter is the cause of the former. Is there a to tell the indexer to look past the mount point?

share|improve this question

5 Answers 5

up vote 3 down vote accepted

After much searching, I found this: http://support.microsoft.com/kb/260207

It explains that drives mounted to folders are not indexed BY DESIGN.

It does not explain what kind of brain dead design this is, or what the reasons are.

share|improve this answer

They explain a bit more about this "issue" here:

Monitoring the USN change journal is new to WS 3.0. The benefit is that we can use the journal change log to determine file changes without rescanning the files on the drive, even if the search service is not running.

In the thread, they give a link to a Windows Search add-in which may work with Windows 7, but only for the 32-bit versioon so I cannot confirm it.

  • Supported Operating Systems: Windows Server 2003; Windows Server 2003 Service Pack 1; Windows Vista; Windows XP Service Pack 2

    Note x64 bit installations are not supported

    • Windows Desktop Search 03.00.0000.XXXX or later versions
    • Windows Search 04.00.6001.XXXXX

I'm not sure which version of Windows Search is included in Windows 7 though. The Indexer Gadget returns "Windows Search version 6.1.7600.16385" but that's the version of Windows 7. Maybe Windows Search doesn't have a separate version number anymore?

share|improve this answer
1  
I have 64 bit. This helps a little. –  Matthew Scouten Nov 22 '09 at 2:50
    
This got me on the right path. the short term solution was to give the drive a letter as well as a mountpoint. the real solution is to not mount the drive, but use libraries to point to the files. –  Matthew Scouten Dec 5 '09 at 6:49

Have you check in "Indexing options", "Modify"? From there you can select drives to be indexed.

share|improve this answer
1  
I have been all over the indexing options, before I came here. The drive does not have a letter and does not appear in that list. It's mounted rather then lettered –  Matthew Scouten Nov 19 '09 at 7:47

I had a similar problem and was recommended to install Windows Desktop Search Addin for Networks, - works well for me now. http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=f7e981d9-5a3b-4872-a07e-220761e27283

share|improve this answer
    
it's not available for 64-bit –  Matthew Scouten Nov 22 '09 at 22:20

I have a similar issue on Windows 7 64bit. What I found is that if you (through Explorer) go to the folder to which the drive is mounted to, and then go into a subfolder, and the type something in the search textbox in the upper right corner, you will get a popup asking you whether you want to index this “unindexed” folder. If you click yes, the indexing service will index the folder.

Now I have no idea how to remove this location from the index as it doesn’t show up in the “Indexed locations” window. But the files are indexed, no doubt! EDIT: It seems that after the folder is deleted or unmounted, one can see the paths in “Indexed locations” window as unavailable.

One could tweak the registry and add mountpoints manually: see here

I also find thet my mount point is correctly registered here: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\UsnNotifier\Windows\Volumes

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.