Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to move from Chrome Dev Tools to Firefox (27.0.1) for day-to-day debugging, however I keep hitting a problem in the inspector that can only be fixed by restarting Firefox.

The first time I load a page I get full access to the DOM, however on subsequent loads/refreshes I get this in the Inspector window:

enter image description here

Clicking the 'Show all 307 Nodes' button has no effect. Clicking On the collapse node button also has no effect. My Rules/Computed/Fonts/Box Model panels are all empty.

What can I do to fix this?

share|improve this question
    
whats your firefox version? –  BlueBerry - vignesh4303 Mar 7 at 12:25
    
@BlueBerry-vignesh4303 27.0.1 (Added to Q) –  1ndivisible Mar 7 at 13:24

2 Answers 2

up vote 3 down vote accepted

I think you are bumping into bug 950732. This was fixed in Firefox 29, which you can get by downloading Aurora.

There are a lot of new features and bug fixes (like this) for web developers that are landing with the latest browser versions, and by using Aurora you can get a chance to use them earlier.

share|improve this answer

The node inspect button in the devtools has moved from the inspector-panel toolbar, on the left, to the toolbox toolbar, on the right:

new node highlighter position in the devtools

The highlighter is shown as you hover over nodes in the markup-panel (instead of having to click on them)

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.