Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 64-bit machine. I downloaded a (paid, legitimate) copy of Microsoft Office 2010 in ISO format. I followed the directions provided, first using 7-zip to unpack the ISO and then, when that didn't seem to work, WinRAR. But I kept getting an error message saying "OSETUP.DLL digital signature does not validate or is not present".

I then tried mounting the ISO (using SlySoft Virtual CloneDrive). Everything mounted correctly, but the error message persisted.

I read several help forums and apparently this is a common problem (going back to Office 2007), but none of the recommendations (including from the Microsoft support staff) have worked.

It's been over an hour and I'm running out of things to try. Any suggestions as to what might be wrong?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I found this answer after over an hour of searching, buried deep within a Technet forum.

If you've tried all of the above and nothing else works, try disabling your anti-virus software and then redownloading the ISO. Apparently, some AV software (mine is Kaspersky), in an effort to protect your computer, will inadvertently (and silently) corrupt the OSETUP.DLL file. After temporarily disabling my AV and redownloading the ISO, everything worked as it was supposed to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.