Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every so often, in other words intermittently, Chrome, FireFox and IE hang for a long time or sometimes forever and don't display, or don't fully display, a localhost page. A simple test.htm page can either load quickly, or take forever to load.

I am testing this by reloading a page with ^R, or with ^F5 (which issues no-cashe).

Opera and Safari don't do this, or if they do it isn't noticeable.

If I've got several browser open at the same time. Once one browser hangs up and can't display a page, and shows that little wherly gig, then all of them will hang up and not be able to reload the page, ..until the first one clears.

I can clear it either by restarting Apache, switchine WiFi on or off, or hitting escape, (but escape only stops the current attempt as the next attempt will also fail).

It's almost like Apache is crashing in some way.


Here is some of what I've tried:

  • Editing etc/hosts as recommended by others, to: 127.0.0.1 locahost.

  • Getting rid of .htaccess and reducing httpd.conf to bare minimum (see below):

  • Simplifying the pages I'm trying to use, e.g. breaking down what I can.


My setup: Win7-x64, Apache Lounge VC11, Apache 2.4.7 (Win32) OpenSSL/1.0.1e

No errors reported in the apache log file. I've deleted .htacess.

Since I'm serving from localhost, if I disable my WiFi this will usually un-stick a waiting page. Likewise, if a page sticks while WiFi is disabled, enabling it will un-stick a waiting page. It's crazy. It's like it's trying to get something from the network. (And yes, I do run virus software.)

Also I've pretty much ruled out php by testing with .html files.


ServerRoot "c:/Program Files (x86)/Apache24"

# MODULES
LoadModule access_compat_module modules/mod_access_compat.so
LoadModule alias_module         modules/mod_alias.so
LoadModule authz_core_module    modules/mod_authz_core.so
LoadModule expires_module       modules/mod_expires.so
LoadModule headers_module       modules/mod_headers.so
LoadModule log_config_module    modules/mod_log_config.so   
LoadModule mime_module          modules/mod_mime.so
LoadModule negotiation_module   modules/mod_negotiation.so
LoadModule php5_module          "c:/Program Files (x86)/php/php5apache2_4.dll"

LoadModule setenvif_module      modules/mod_setenvif.so
LoadModule socache_shmcb_module modules/mod_socache_shmcb.so
LoadModule ssl_module           modules/mod_ssl.so



# DIRS / FILES
<Directory />
    AllowOverride none
    Require all denied
</Directory>

<Directory "C:/home/usedsoup/public_html">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

<Files ".ht*">
    Require all denied
</Files>


# ERRORS & LOGS
ErrorDocument 404 "/Missing.php"
ErrorLog "logs/error.log"
LogLevel warn
<IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t %k %D \"%r\" %>s %b" common
    CustomLog "logs/access.log" common
</IfModule>



# SSL
Include conf/extra/httpd-ssl.conf
<IfModule ssl_module>
    SSLRandomSeed startup builtin
    SSLRandomSeed connect builtin
</IfModule>


# PHP
PHPIniDir "c:/Program Files (x86)/php"
AddHandler application/x-httpd-php .php
<FilesMatch \.php$>
    SetHandler application/x-httpd-php
</FilesMatch>


# Virtual hosts
Listen 80
<VirtualHost *:80>
    DocumentRoot "c:/Home/usedsoup/public_html"
    ServerName http://localhost:80
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "c:/Home/usedsoup/public_html"
    ServerName https://secure.localhost:80
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "c:/Home/usedsoup/public_html"
    ServerName http://i.localhost:80
</VirtualHost>
share|improve this question
    
OpenSSL 1.0.1e has a critical security bug, update it –  miniBill Mar 11 at 5:57

1 Answer 1

I think I found a solution.

AcceptFilter http none
AcceptFilter https none 

Look here.

share|improve this answer
    
Please describe the solution briefly here too, we want to avoid linkrot –  miniBill Mar 11 at 5:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.