Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently got different connection to the Internet. It is via 4G, provided by Optimus.

Now when I am downloading something, approximately after downloading 100MB, the speed goes all the way down to 0KBs and goes back up. Using browsers, the download stops and doesn't continue since the internet kind of disconnects for a really short period of time.

I realized that through skype, steam and uGet or KGET, after reaching 0KBs, the download continues. It is troublesome since I can't download anything through any browser (I've tested Opera, Firefox, IE, Chrome).

The same happens while loading a video. After a few minutes of buffering, it completely stops, and the way to fix, is to either reload the page or change quality of the video.

I'm using Huawei E5372.

This happens with every computer while connected to this internet. However, it did not happen with my old internet provider.

share|improve this question
    
So, to summarize: You have a setup (multiple computers) which worked fine when you accessed the Internet via your old ISP. You changed provider and now the connection stalls after 100MB. (The connection, not the programs. This is why I removed all the program tags). Some programs will automatically retry and that works. Others (your browsers) require you to manually intervene. –  Hennes Mar 9 at 11:34
    
Now the real question: What is different about the browsers? E.g. are you using a proxy? Is your ISP using a transparent proxy. Is your new ISP deliberately managing bandwidth? What happens if you connect/download from a webpage not on port 80 (and thus possibly not parsed by a proxy). What happens if you keep a continuous ping or traceroute open the the server you are downloading from (e.g. use mtr or its windows equivalent). ... ... –  Hennes Mar 9 at 11:39
    
Difference about the browsers? I'm not sure if there's any difference, I just used them for testing purposes and they all had the same result. I'm not using a proxy. I'm not sure if my ISP is using a transparent proxy, they most likely aren't. If I download something from, lets say a Jar (Runescape's cache), it will work fine. Whenever I download something over Skype, it works as well. So the problem seems to be on port 80/browser. The MTR works as it should, it doesn't stop responding, also the website is up and working functionally like it normally would. –  Omnee Mar 9 at 11:55
    
The problem just being on port 80 makes me think of a transparent proxy. Can you try a large ( >100MB download ) from a https site? –  Hennes Mar 9 at 12:12
    
Tried a 300MB file from Dropbox, stopped at ~120MB –  Omnee Mar 9 at 12:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.