Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Newbie here. Trying desperately to overcome this problem of neon-like color and distortion when I play a video. Often the sidebars of basically non-video screens (like email) have the same sort of wild colors and they often flicker.

It seems the consensus advice is to disable the hardware acceleration of Adobe Flash Player in the Settings tab (seen by right clicking on the video), but I've tried that and the box won't uncheck.

I've also tried the F11 method (below). No luck. What I need help with is implementing Method #1 (below, italicized). I know how to use the terminal and the advice doesn't seem that complicated, but if you could break it down into a step-by-step process for me, I would really appreciate it. Thanks! P.S. the problem and solution as stated below are from the superuser forum.


Problem:
The latest official version (and supposedly the last version for Linux) of Flash player has some interesting issues on Linux systems. The biggest issues which have summarily been confirmed on the Ubuntu forums are:

YouTube videos have a red / blue color overlay Flash content shows through on other windows How do I fix this?

Solution:
The commonly accepted solution to this issue appears to be disabling hardware acceleration for Flash player. This is usually accomplished by right-clicking the Flash content, selecting Settings and then uncheck the Enable Hardware Acceleration option, but in the affected version of Flash player, it isn't possible to uncheck that particular option (clicking it does absolutely nothing). As such, the following two work-arounds exist for disabling hardware acceleration:

Method 1: Create (or edit, if it already exists) the file /etc/adobe/mms.cfg and add the following configuration parameter to it: EnableLinuxHWVideoDecode=0
Method 2: Open a YouTube video and enable fullscreen mode. Then right-click, select Settings and uncheck the Enable Hardware Acceleration option. For some reason this only seems to work when Flash player is in fullscreen mode.

share|improve this question
    
Please clean this up. If you want to copy your question from Ask Ubuntu, you need to click on the edit link and copy the source. You might want to delete those parts about being from Super User, that's where you're posting now. Also, please explain if the problem and solution you are quoting are relevant and if the solution helped. Finally, cross-posting is strongly discouraged. Please delete your questions from Ask Ubuntu if you want to ask the same thing here. –  terdon Mar 10 at 2:09
    
terdon, I had no intention of cross-posting or anything else. These question forums are so new to me, I'm finding them difficult to navigate. I was simply Googling looking for an answer to my problem and came across the Superuser forum with what looked to be an answer. I included the details about the superuser post to be as informative as I could be. I did not know Superuser and AskUbuntu were connected. It seems my post has been edited so I won't edit it. I deleted all my questions regarding this issue from AskUbuntu. Please let me know if there is anything else I need to do. Thank you.Gregg –  user250093 Mar 10 at 20:09
    
I know you didn't! That's why I left a comment explaining the protocol to you. Does the solution below work for you? Oh, and I recommend taking the tour to get an idea of how these sites work. –  terdon Mar 10 at 20:11
    
terdon, thx for responding. I will take the tour. And no, I could not get the below solution to work (although from what I've read I think it will). And I'm not sure how to post (maybe I will after the tour) about that. Briefly, I tried his first entry and it didn't work. Then I didn't know how to become superuser in order to run the second command. Thanks. –  user250093 Mar 10 at 20:20
    
In that case, leave a comment under the answer explaining the problem and asking for clarification. –  terdon Mar 10 at 20:21

1 Answer 1

"Method 1: Create (or edit, if it already exists) the file /etc/adobe/mms.cfg and add the following configuration parameter to it: EnableLinuxHWVideoDecode=0"

$ sudo nano /etc/adobe/mms.cfg

This will open the mms.cfg file in a text editing program called nano which should exist on your system. Sudo tells linux to run this command with privileges as the files in the /etc directory are system files. If you aren't in sudoers, you will need become superuser, and then run the command without sudo:

$ su
# nano /etc/adobe/mms.cfg

Edit: The above is two commands - including the linux prompt at the beginning of each line. Hence, while you have a '$' prompt, type in su<Enter>. This will make you superuser. Linux lets you know you are superuser by changing the prompt to a '#'. Then, from the '#' prompt, type nano /etc/adobe/mms.cfg<Enter>

NB: If this comes up with a 'command not found' error, you may not have nano on your system. This means you'll probably need to edit the file in vi. Vi is not intuitively obvious for new users due to its modes. It is probably easier to show you how to add nano to your system than to show you how to edit it in vi.

Once you're in nano editing the file, add:

EnableLinuxHWVideoDecode=0

to the file on its own line. If it is blank, just put it in as line 1, otherwise, look for some appropriate location, or add it to the end. When editing /etc files, I usually add a comment line immediately above my edits, something like:

# added by mcalex to make flash run properly.  see:superuser.com/questions/blahblah #

but that's just my paranoia. The comment makes most sense above the command, but can go anywhere without affecting what you're doing. It doesn't matter what goes in the comment; it is for your assistance if you need to look at the file a year (or 5 years) later.

Now the file needs to be saved. In nano, use Ctrl-x to exit, and nano will ask if you want to save the file - hit y, and then <Enter> when it provides the file name. You need to look at the bottom of the screen to see the nano prompts for saving & filename.

That should do it.

share|improve this answer
    
Wish I could give you +2 for suggesting adding a comment. –  terdon Mar 10 at 2:05
    
Thx for helping. I tried the first command and the reply was "command not found." So I tried the second command and the entire command was truncated to "su" and then on the line below it, it had "command not found" and below that the original command. So I went to log in as superuser but didn't know how. I Googled how to become Superuser but that seemed confusing (and dangerous if I did the wrong thing). So that's my next question: how do I become superuser so I can implement the $ su # nano /etc/adobe/mms.cfg command? Thanks. –  user250093 Mar 10 at 20:44
    
@user250093 check the edit –  mcalex Mar 11 at 4:41
    
Almost home. Had to do sudo su instead of su to get to be superuser. Then had # prompt. Nano came up. Nano was empty so put EnableLinuxHWVideoDecode=0 on first line. Then was unsure if I could put your "#added by mcalex..." underneath that (as you said to put it above the edit). And more importantly I wasn't sure if I should save it or not. You gave no instructions to do so (even though I felt like I should) so I just Xed out of Nano. Anyway, I didn't know how to save in Nano. I rebooted and the distorted video was still there. Should be easy if you clarify about my 2 questions. Thanks much! –  user250093 Mar 11 at 7:12
    
@user250093 edited again. –  mcalex Mar 11 at 9:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.