Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Cheers!

I dislike disobedience from my system. When I want to explicitly kill Nautilus with kill or killall, I am no longer able to do so. Previously I could disable this erroneous behavior (which even Windows do not exhibit!) through gnome-session-properties, however, it is no longer possible to set the "restart style" there (or whatever it was called).

What is nowadays the correct way to disable nautilus autorestart under gnome?


Reasons:

  • I'm writing a piece of software that's painting directly into X11 root window. Nautilus is interfering.
  • Compiz has a wallpapers plugin which Nautilus is painting over.
share|improve this question
1  
Why do you wanna kill Nautilus at all? –  Bobby Nov 19 '09 at 16:22
add comment

3 Answers

Yes, this annoys me, too.

What's happening in my case with xfce is that Nautilus is automatically registering with the session manager and telling the session manager to restart Nautilus when it terminates. You can prevent it from doing this by using the following undocumented command-line option:

nautilus --sm-disable

(There is no ~/.config/autostart entry.)

However I still haven't yet found how to make it behave like a normal application and terminate when its last window closes.

In addition you can prevent Nautilus from managing the desktop by changing the /apps/nautilus/preferences/show_desktop registry key.

share|improve this answer
add comment

Edit the appropriate file in ~/.config/autostart/ and change: X-GNOME-AutoRestart=true to: X-GNOME-AutoRestart=false

If you want to stop something like Nautilus, I suspect you may be able to override system defaults by copying the nautilus .desktop file to that folder, or else you'll have to edit the system file.

http://live.gnome.org/SessionManagement/GnomeSession#A8._Termination

share|improve this answer
    
This sounds about right, I'll try it and let you know. –  Ivan Vučica Dec 12 '09 at 11:27
add comment

For me the file in ~/.config/autostart/ did not help, the one in /usr/share/applications does, so...

in total do:

gconftool-2 -s -t bool /desktop/gnome/background/draw_background false
gconftool-2 -s -t bool /apps/nautilus/preferences/show_desktop false

and

sudo gedit /usr/share/applications/nautilus.desktop

change to:

X-GNOME-AutoRestart=false

(found here)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.