Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My MS Office 2007 somehow got corrupted on windows 7. When i open any app (word, excel, access, etc.) from MS Office, i get this message :-

word failed to start correctly last time. Starting Word in safe mode will help you correct or isolate a startup problem in order to successfully start the program. Some functionality may be disabled in this mode.

I tried it in safe mode...but no luck. I tried to repair MS Office with Installation CD, but it didnt help either. I can't even uninstall MS Office from control panel.

So how to get rid of this problem or how to uninstall it without using Add/Remove Program wizard.

share|improve this question
    
Perhaps superuser.com would be a better forum for this question. –  user12826 Nov 19 '09 at 16:25
add comment

migrated from stackoverflow.com Nov 19 '09 at 16:41

This question came from our site for professional and enthusiast programmers.

3 Answers

Two Microsoft articles.

See first :
How do I uninstall the 2007 Office suites if I cannot uninstall it by using the "Add or Remove Programs" feature?

This describes how to automatically remove Office 2007.
If it doesn't work, use the method described in second article:

How to manually uninstall the 2007 Office system if you cannot uninstall it by using the "Add or Remove Programs" feature

share|improve this answer
add comment

You can roll back to a system restore point before you installed Office (or before it started acting wonky).

Provided, of course, that you have System Restore enabled and that Office hasn't been doing that for the last few millennia, in which case it might be a little difficult to find that restore point.

Also keep in mind that any changes to the system in that time are rolled back too, so drivers, software, etc. from that period are gone as well. Still, for problems that occurred relatively recently it's a nice solution in many cases.

share|improve this answer
    
I really advise against this approach. Last resort maybe... –  a432511 Nov 19 '09 at 16:26
add comment

I have seen that issue before. You need to follow some steps to manually remove it. Try the instructions found @ http://support.microsoft.com/kb/928218

share|improve this answer
    
I seem to recall that this is the result off corrupted registry access levels, there is a script out there somewhere to repair this. It happened in Vista too. –  Lazarus Nov 19 '09 at 16:26
    
There are tools to repair registry permissions, but I think following the Microsoft guide is better for the average user. More step by step less likely to screw something up sort of thing. –  a432511 Nov 19 '09 at 16:28
    
Using an automatic registery cleaner like CCleaner might help some by removing old or invalid entries in the registery. –  Chris Nov 19 '09 at 16:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.