Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried to change permissions on a directory to 775. I've used this command:

sudo chmod -v 775 /vagrant/app/cache

It tells me that the command executed successfully:

mode of `/vagrant/app/cache' changed from 0755 (rwxr-xr-x) to 0775 (rwxrwxr-x)

however, when I then run:

ls -l /vagrant/app

the cache directory is listed as:

drwxr-xr-x 1 vagrant vagrant   136 Mar  5 12:03 cache

I'm using Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-23-generic x86_64).

Can anyone explain why this is happening and what I should do to fix it?!

UPDATE: This is the output from

df -T

I think it shows that the filesystem is vboxsf. I'm using VirtualBox...

Filesystem                 Type     1K-blocks      Used Available Use% Mounted on
/dev/mapper/precise64-root ext4      82711212   2904248  75664680   4% /
udev                       devtmpfs    178072         4    178068   1% /dev
tmpfs                      tmpfs        74852       284     74568   1% /run
none                       tmpfs         5120         0      5120   0% /run/lock
none                       tmpfs       187128         0    187128   0% /run/shm
/dev/sda1                  ext2        233191     24966    195784  12% /boot
/srv                       vboxsf   117649480 106406988  11242492  91% /srv
/vagrant                   vboxsf   117649480 106406988  11242492  91% /vagrant
share|improve this question
    
What file system are you using? There is a bug report on debian which might be the cause, but depends on your system. bugs.debian.org/cgi-bin/bugreport.cgi?bug=296836 – Matthew Williams Mar 10 '14 at 19:43
    
Sorry if this sounds stupid but... I don't know! How can I find out?! – musoNic80 Mar 10 '14 at 22:20
    
df -T will give you the filesystem. Once you have this have a look at the above link and see if it could be your problem. – Matthew Williams Mar 11 '14 at 8:31
    
I've edited the question to include the output from that command. I don't think the bug report is relevant to my filesystem. – musoNic80 Mar 11 '14 at 8:59
    
I agree. Seems your problem lies elsewhere. Let me do some digging and get back to you. – Matthew Williams Mar 11 '14 at 9:03

Found the answer here:

http://jeremykendall.net/2013/08/09/vagrant-synced-folders-permissions/

You can set mount options in the vagrantfile and since the vagrant directory is a shared directory that allows you to set permissions properly.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .