Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Let me state the problem. My ISP provides a 60mbps connection to my place. The router is set to abgn mode (to support older devices to) and runs on 2.4GHz.

I've got few devices that are connected to that network and some of them do support at least 802.11n standard. Below are speedtest results for them:

  1. MacBook Pro with Mavericks
  2. PC with Win7x64 (Intel DualBand Wireless AC 7260 on-board adapter)

There's no way I could get anywhere near the speeds of my Mac on my PC if it comes to the connection. It's always around 20mbps. I did try with different USB WiFi cards (both from TPLink in 802.11n standard) but it was the same.

Wireless Network Connection Status states that it's connected with Speed 130.0 Mbps:

enter image description here

Any ideas?

share|improve this question
What actual speed does your PC connect at? Are you sure that your mac is not connecting to 5ghz network? Is your router running up-to-date firmware? – Mxx Mar 11 '14 at 4:28
@Mxx I've got only 2.4GHz enabled on my router. Security is WPA2/AES and WMM is enabled. – rafek Mar 11 '14 at 4:33
How are you measuring the speed on your PC? (Be as precise and specific as you can, please.) – David Schwartz Mar 11 '14 at 6:01
Just a note, The "130.0Mbps" is not the the speed at which you are connected to your isp, but rather your LAN connection (from your computer to your router). As davidgo says below, your Mac must just have a better WLAN card. – imtheman Mar 11 '14 at 6:16
@DavidSchwartz I'm using – rafek Mar 11 '14 at 7:45

Take your WAN link out of the equation by doing some performance tests with a good local performance tool like IPerf. Plug a machine with a good gigabit Ethernet card into a LAN port on your router, and make that machine your IPerf client (IPerf, by default, sends from client to server). Make your wireless machine your IPerf server.

Run your first test with the default TCP window sizes that your OSes pick. Then run it again but force a 2MiB window by adding -w 2m to the IPerf options on both ends.

Your 130mbps PHY rate (the physical signaling rate) suggests an 802.11n, 2x2:2, HT20, Long Guard Interval connection. Assuming an otherwise idle network and no significant interference, you should be able to get 65-104 mbps of TCP-over-IPv4 throughput over that link (that is, 50%-80% efficiency), when tested with an efficient tool like IPerf, with sufficient TCP window sizes.

If forcing a proper TCP window size solves your problem, you can probably find some Windows registry settings to tweak to force a larger window size.

share|improve this answer

I think this could be a number of things, and most likely a combination of a number of things including -

  1. Whether the cards in the PC are MIMO capable. The Apple device probably includes multiple aerials in a MIMO configurations (2x2 mimo support for the Mac Book Pro I think) If the PC cards don't have this feature, and I'd imagine most don't, that very likely explains a good chunk, if not all the performance difference. It looks to me that the 7260 is 2x2, but I'm guessing its 1 per frequency rather then 2 on 2.4 gig for MIMO. (See first answer to this question). I could be wrong here.

  2. The distance between the devices - if the Mac is closer to the router (or less obstructed or has less interference) it will get a stronger signal.

  3. The type and sensitivity of the network cards - not all cards are made equal, and not all antennas are made equal.

share|improve this answer
Thanks for the answer. Distance of them two computers is equal, thus that's not a problem. If the 7260 has 1 antenna per frequency, then is there any possibility to make it work faster? – rafek Mar 11 '14 at 7:47
You should try using a wired connection for testing as the problem may not be your WiFi card. (I thought you were complaining of issues within your lan. The first step to resolving speed issues is to test performance to your router and other directly connected pc's – davidgo Mar 11 '14 at 18:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .