Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question is exactly what is says on the tin.

At the moment, with default settings, all ftp:// links (even bookmarks in the Places menu created with "Connect to Server", which opens in Nautilus the first time) open in Firefox (which can only read, not write). So I have to copy the URL into nautilus to open it with nautilus to save files.

How can I make these links open in nautilus?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

You can change the associations in gconf-editor. Expand desktop -> gnome -> url-handlers and find the entry for FTP and change the command to your preferences.

share|improve this answer

If that doesn't work, try to edit or add:

x-scheme-handler/ftp=nautilus to ~/.local/share/applications/mimeapps.list

or

x-scheme-handler/ftp=nautilus-folder-handler.desktop to /etc/gnome/defaults.list

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.