Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In my office, we use a custom right-click menu in .dwg files to allow the users to choose which version of AutoCAD they want to open the file.

It howover requires that AutoCAD don't mess with the file association of DWG files, otherwise the custom menu is lost.

Once the menu is installed, the first time AutoCAD is open it detects it is not the default DWG launcher and asks:

AutoCAD - DWG Association

I choose "Do not associate DWG files with AutoCAD", to preserve the right-click menu configuration.

Howover, I'm having an issue with a workstation where this window is not popping up, and it is reassociating DWG files with AutoCAD, what ruins the whole thing.

Is there some way I can reset this setting and make it ask again or simply configure this behaviour somewhere?

share|improve this question

2 Answers 2

Have you tried some of this?

I step upon this just now, I'm currently trying to apply the /nologo switch when I open a DWG file by double-clicking on it and this shows in Google (along with your question). I didn't try any of this yet. Hope this helps you.

share|improve this answer
Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Feb 14 at 6:53

I managed to workaround the problem, and even have a better handling of .dwg files behaviour by changing the way I install the file association.

Instead of modifying HKEY_CLASSES_ROOT\.dwg, I just leave that alone and modify HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.dwg\UserChoice instead.

This overrides the default association for .dwg files, and AutoCAD won't even bother.

If anyone is curious, this is what I'm doing:


Windows Registry Editor Version 5.00




@="Open with AutoCAD 2014 / 2006"

@="C:\\Program Files\\Autodesk\\AutoCAD 2014\\en-US\\acadficn.dll,49"


@="Open with AutoCAD 2006"

@="\"C:\\Program Files (x86)\\AutoCAD 2006\\acad.exe\" \"%1\""




@="Open with AutoCAD 2014"

@="\"C:\\Program Files\\Autodesk\\AutoCAD 2014\\acad.exe\" \"%1\""




This allows both AutoCAD 2006 and AutoCAD 2014 to coexist on the same system, AutoCAD 2014 being the default one, and you can right-click any .dwg file and open with AutoCAD 2006.

This was created because some of our architects are relutant to upgrade from AutoCAD 2006, and some of our scripts are only compatible with AutoCAD 2006.

This does not answer the fundamental question though, so I'm not accepting it as answer. How to reset the DWG association setting on AutoCAD remains a mystery.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.