Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install a library via pip. I have a problem with SSL certificate, even when using the --cert. Trying this on windows (pip version 1.5.4,python version 2.7.6):

pip --cert C:\tmp\cacert.pem install robotframework-archivelibrary --proxy http://myproxy

Getting page Could not fetch URL connection error: [Errno 1] _ssl.c:507: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

Any idea?

Thank you.

share|improve this question

I had a similar error messages which I realised was due to our corporate firewall intercepting SSL (i.e. a transparent SSL proxy). I exported the root CA cert that signs the firewall certificate in .pem format and appended it to the following file:


That resolved my issue. Your issue might not be exactly the same, but if you get the right CA certificates into the above cacert.pem I'm sure you can get passed your SSL certificate verification failure.

share|improve this answer
Could you elaborate on how do one export root CA cert? – Eran Jan 21 '15 at 13:08
Yes, I'm unclear on which root CA is exported to where -- are we grabbing the source repo's root CA and passing it on the command line, as well as exporting to the firewall via the cacert.pem file in Python's site-packages? – rholmes Sep 10 '15 at 1:58
I tried 5 different cacert.pem files in python folders but eventually one of them worked: C:\Python27\Lib\site-packages\certifi\cacert.pem One of them also got conda to work – endolith May 6 at 15:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.