Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not sure where to start, there seem to be several issues with this build. I'll run down the specs first. That should be a good start.

Specification

  • MB: ASUS A88X-PLUS FM2+ AMD A88X FCH
  • CPU: AMD A10-7850K 3.7 GHz APU
  • RAM: Corsair 8 GB XMS3 PC12800 1600 MHz (2x4 GB)
  • SSD: Samsung 840 EVO 250 GB SATA 3.0 TLC
  • HDD: WD Caviar Blue 1 TB
  • ODD: HP TS-H653 SATA DVD-RW
  • OS: Windows 7 Pro 64-bit OEM

Problem 1 - drivers: Installing the components was easy. The problems began with installing the operating system. I didn't have an optical drive at hand and Windows is still delivered on DVD. So I took an external DVD drive, plugged it into a USB port and the computer booted from it. But then right before the Windows 7 setup program shows you the option to do an upgrade or custom (advanced) installation, it started complaining about drivers for CD/DVD drive.

Q: Can someone explain to me how Windows 7 was able to boot from the USB connected, DVD drive, but is not able to continue the installation without providing additional drivers for it?

Of course, I didn't have any special drivers for it, I didn't even know what brand or model it was, so Google was a no go. There was not a single label on the thing. (From the looks of it, it's an ATAPI drive from a laptop inside an external case with ATAPI-USB converter.)

Problem 2 - expanding files: So I pulled out the ODD you see above from a recent model HP desktop PC. I plugged that in, booted and there was no whining about drivers this time. I selected the SSD for the system partition in the custom installation dialog. Windows starts installing and I thought my troubles were over, but a few minutes later I realized that it is stuck at expanding files.

Installing Windows...

Copying Windows files [check]
Expanding Windows files [5%]
Installing features
Installing updates
Completing installation

Knowing that a Windows 7 installation recently took more time than usual on another PC, I decided not to touch it and let it do its thing. But 120 minutes later it was still at 5%. So I left it unattended, when I came back the PC was off. I left my college in charge, he might have shut it down after realizing it wasn't going to budge any year soon.

Q: Do I need drivers for an SSD drive at boot or OS install time, or have it specially prepped for OS install beforehand?

I read some forum threads on various websites about getting stuck at expanding files. Most of the guys seem to blame the various controller chip makers in early SSD drives. Most of these threads are from 2010 - 2012. My SSD is from 2013 I believe, and SSD drives have evolved since those early days. Other things discussed are IDE vs. AHCI. For all I know AHCI is the preferred language for a modern computer, and it should be enabled on a system like this one, and Windows 7 should not have any problems with it.

Problem 3 - red LED: I haven't been able to replicate the problem to see what triggers it, but sometimes when I enter BIOS setup and then save and exit (without even making any changes), the PC is still powered on but it doesn't seem to POST again. I open the case and I see a red LED is lit up next to the ATX main power connector. Motherboard manual says it's a "DRAM LED".

DRAM LED checks the DRAM in sequence during motherboard booting process. If an error is found, the LED next to the error device will continue lighting until the problem is solved. This user-friendly design provides an intuitional way to locate the root problem within a second.

Q: Is this LED actually saying there is something wrong with my RAM memory?

If I press the Reset button on the case nothing happens, it's as if the entire motherboard becomes unresponsive. I can't press DEL or F2 to enter BIOS, nothing. I can only press and hold Power button to power off and then power it back on again. If I enter BIOS once more, don't change anything, and save and exit once more, it does not get stuck again, it reboots normally. So I'm not sure what triggers this behavior.

I have been using all default BIOS settings. I did try disabling Fast Boot and enabling "full initialization" for USB devices (while using the USB connected DVD drive). I have then set it back to optimized defaults.

Honestly, I haven't tried disabling AHCI, because that's actually something I would want to have. So even if it could work with IDE mode, it's not something I want to get stuck with. Having read a few threads on forums, I know that once you install Windows 7 with the drive in IDE mode, you're stuck with it. It's not as simple as switching back to AHCI in BIOS. You have to actually reinstall Windows to make it use AHCI drivers. There are some workarounds for this, I know, but hey, why bother?... I want AHCI mode from the get go.

Problem 4 - installation continues and then stops: I have now had the HDD disconnected, and moved the SATA cables for the SDD and the ODD to different ports. Then when I powered on, instead of booting from the DVD in ODD it booted from SDD! And the Windows 7 setup seemed to continue from where it left off, and it was stating something like "completing installation" (or similar). But then the screen went to sleep mode and there was no more video signal, but the PC was still running.

Q: How can I be sure this is not caused by having AHCI mode enabled, RAM memory error, or by the SSD drive?

Edit: I think I know now why it's acting up like this. The AMD APU has part number AD785KXBJABOX and it's not listed at all as being support on the ASUS A88X-PLUS product page. My BIOS version is 0501, and the latest seems to be 1002. How do you read this numbers anyway? Is 1002 in fact lower version than 0206 or 0501?

share|improve this question
    
Q1: Your system booted with the BIOS configured to treat USB devices as legacy hardware hich can be accessed via BIOS calls. Once the windows core boots this gets replaced by its own mechnism (and that assumes that you have installed the drivers for that). –  Hennes Mar 12 at 9:59
    
Are you booting in UEFI mode? You must. –  H3br3wHamm3r81 Mar 12 at 10:29
    
How do I tell if I'm booting in UEFI mode? –  sammyg Mar 12 at 10:49
    
I cleared the CMOS using the jumper, then under USB Support I have enabled "Full Initialization", and I have disabled Legacy USB support. Then it booted into Windows 7 and asked me to configure a user name and password. Now it seems to be working... e.g. I have been able to reboot and log onto Windows several times now. –  sammyg Mar 12 at 10:59
    
I'm not sure this will hold. I am worried about that red LED next to ATX connector and RAM memory modules. What does it mean when the PC halts on boot and that LED is lit up? (My PC case has a speaker, but it doesn't give a BIOS beep code when this happens, but I know the speaker works because normally on POST it beeps once.) And I my laptop is giving me headaches because it can't create a bootable USB flash drive with Memtest86+ so I can test the memory. –  sammyg Mar 12 at 11:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.