Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just noticed this today, and now it's really bugging me. Internet Explorer (11 in my case, may not matter), has a delay when you touch buttons or links. Using a mouse is instantaneous, but using a touchscreen adds around a ~500ms delay. Chrome does not have this same delay.

You can try it out yourself by visiting a sight like Bootstrap which uses anchor links on the side menus. Using a mouse, you can navigate instantly in any browser. Using IE specifically with touch creates a delay on every tap.

Most people probably don't notice it since we spend much of our time waiting for pages to load.

How do I turn off this delay?

share|improve this question

Try reducing the latencies here:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\TouchPredict

This made a massive difference on the Surface RT for me.

Don't expect good performance from any Windows touchscreen other than the Surface RT / Pro. The rest are all garbage like Android devices.

share|improve this answer
    
It's not a screen issue. In fact, when you tap, it instantly highlights what you clicked on, but waits to actually fire the event. In any event, I actually answered my own question. – Jason Young Mar 12 '14 at 20:42

I finally found the answer on the Telerik Blog

Summary: This is common, and can be turned off through a number of HTML/JavaScript/CSS solutions.

For me, I just added this CSS to my code:

a[href], button {
    -ms-touch-action: none; /* IE10 */
    touch-action: none;     /* IE11 */
}

It's now instant on my Lenovo, and my Surface 2.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .