Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Over the past few days my ethernet-wired internet connection has started acting up. Here are some of the issues I've encountered:

  1. Websites are intermittently slow to load.
  2. Large downloads routinely fail halfway through.
  3. My SpeedTest results look like a roller coaster
  4. PingPlotter, WireShark (and just regular ping) reports high packet loss/retransmission, seemingly all over place, including within our internal network.

Ingredient stack:

  1. 30 Mbit Cable Internet
  2. Asus RT-N66U Gigabit Router
  3. TP-Link Gigabit switch
  4. MSI 970A-G46 Motherboard, with integrated Realtek 8111E NIC
  5. Windows 8.1 N Enterprise

Now here's where it starts to get interesting:

  1. This computer was built as part of a batch of 5 for our new office. All 5 have identical hardware, network topology, etc. and mine is the only one that seems to be acting up.
  2. I've tried swapping out ethernet cables, changing ports on the switch, bypassing the switch and plugging straight into the router, etc. Nothing fixes the issue.
  3. I've tried booting into Knoppix with a USB stick, and the issue persists.
  4. At no point and time does the Ethernet Adapter report being disconnected, it seems to believe it's functioning just fine.

All of this leads me to believe that it must be hardware problem with the motherboard's onboard NIC. But this is just a hunch on my part as I don't know of any way to actually confirm this.

Are there any diagnostic tools that can help me confirm where exactly the problem lies? Is it easy to prove (or disprove) my theory that it's the integrated NIC causing trouble?

share|improve this question
    
It looks like you've already put way more work into this that it would take to just replace the NIC. And it sounds like you've eliminated everything else. –  user3050461 Mar 12 at 21:00
    
Is that a managed switch you could check the log on for collisions or something like that? Is there any cabling you could swap somehow? –  TheUser1024 Mar 12 at 21:06
1  
I agree with @user3050461, the easiest way to prove it (do you need to prove it or fix it btw.?) would be to have a replacement NIC make the problem vanish while the old NIC would somewhat reproducably show it. USB 2.0 NICs don't do gigabit ethernet, so you might only be showing that it works at 100MBit/s. You might want to try forcing your connection down to that rate btw. and see if that helps. –  TheUser1024 Mar 12 at 21:21
    
Yeah I think you guys are right. I've got a new NIC being shipped to me so I'll stop wasting time on this given that they're so cheap. –  Stephane Beniak Mar 13 at 14:46

2 Answers 2

Swap your NIC card with one from one of the other machines. If you think it's the NIC, test one that you know is working. Also check your drivers. Make sure that you're all using the same driver.

share|improve this answer
1  
The swapping part is unfortunately a bit hard to do with the onboard NICs :-) –  TheUser1024 Mar 12 at 21:02
    
@TheUser1024 Indeed! I'd have to swap an entire motherboard, scrape off some thermal paste, disrupt a coworker's workday, etc. –  Stephane Beniak Mar 12 at 21:08
    
Then bop over to the local hardware store and get a not-integrated NIC. See if that improves the problem. For a 10/100 shouldn't cost more than $10. If you need GB, shouldn't be more than $30. You've already spent that much in time trying to troubleshoot. –  RecentCoin Mar 12 at 21:22
    
I think you're right, I've spent too much time on this. I was just hoping for a way to actually identify the issue correctly though :) –  Stephane Beniak Mar 13 at 14:47
up vote 0 down vote accepted

Turns out the onboard NIC really must have broken. I bought a PCI network card and all is well again.

Unfortunately, I was not able to find a conclusive way of proving that the motherboard's network controller truly was the culprit. But quite frankly, as others here have rightly pointed out, an extra PCI NIC costs on the order of $15 which is much cheaper than debugging for an entire day :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.