Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When using the linux terminal client for mysql, every column with a blob prints out tons of control characters and the terminal has to be reset.

This looks something like the following

   Map: �PNG  IHDR   �      Z=�   tRNS . 8 B��`  gIDATx���yX��ǿ ��B��h-�7Db�.-\�E\Q騵U{��֥�m�?E�IU�u�t

�J)Fm�-IY�Z�^� ("e���!��� ��Ó��9���|�s�{�,�!� �?+V�[������ ���6�`�} �h��V���e�jWEo� �������݇8B?P/�.������]�<�I~��sJle

However, on another server it prints out nicely, on one line like so

          Map: �PNG

I can confirm that these are the exact same image, cloned from one server to the other. I assume it is some setting in one of the mysql servers or clients.

To clarify, I know how to reset the terminal. What I really want is to avoid having to specify every field in my select (SELECT *, rather than listing all 15 non-blob columns).

How do I make it always appear the second way?

share|improve this question

migrated from stackoverflow.com Mar 13 '14 at 0:35

This question came from our site for professional and enthusiast programmers.

2  
Why are you spewing out binary data? In any case, the solution to unwedging the tty is to type "^jreset^j" (omit the '"', ^j is ctrl-J) – vonbrand Mar 13 '14 at 0:25
    
@vonbrand it is a png image stored in the field as binary. I would rather it not 'spew out', like on the other server. – mehtunguh Mar 13 '14 at 1:22

You must log in to answer this question.

Browse other questions tagged .