Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use an I-Concepts floppy keyboard via USB on my Toshiba laptop (Satellite C55-A; win 8.0). Up until about 30 minutes ago, it worked fine. Then I walked away and came back to it, it and there are keys no longer working:

space insert delete down arrow

Everything else seems fine.

I tried uninstalling the keyboard in the Device Manager, then reinstalling it after removing it from the computer (removed the USB plug), rebooted and put it back in. This didn't fix it.

I tried using a brand new identical keyboard, and got the exact same problems. So it has to be the computer, not the keyboard.

I've run virus scans and run them regularly, my CPU is clean. Does anyone have any suggestions? It's tough to get by without having the space key available (I am obviously typing form the laptop's' keyboard).

I also tried using a different USB port, the problem didn't go away.

The Number Pad is also not functioning.

share|improve this question
    
Out of curiousity, do other external keyboards work, or is it just the one model. –  sww1235 May 18 at 17:19

1 Answer 1

I don't know if removing the device in device manager will also remove drivers, so i would attempt to remove the drivers as well. It appears to be a issue with the computer itself as stated in your question, so the drivers would be the next place i would look.

share|improve this answer
    
I already tried the drivers in device manager, they are updated and functional. It's only the select (but important) keys which stopped working. –  user307324 Mar 13 at 4:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.