Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need some help fast please. I recently booted up my gaming rig after swapping out a 7970 graphics card and upon system boot up, as the Windows 7 logo appeared the system crashes and a BSOD appears for a split millisecond and I'm asked to start up repair Windows or start Windows normally. However when I click startup repair, a black error screen appears with the following error message:

Windows Boot Manager

Windows failed to start. A recent hardware or software change might be the cause.

To fix the problem:

  1. Insert your Windows installation disc and restart your computer. (I don’t have the disc in my current country.)
  2. Choose your language settings, and then click "Next."
  3. Click “repair your computer.” (I did but it was just going back to windows error recovery page.)

Status: 0xc000000e

Info: The boot selection failed because a required device is inaccessible.

Now I've fixed this before multiple times. except this instance nothing seems to work. I've tried the following:

  • check for any unplugged or loose cables
  • Re installed my RAM
  • Booted with on-board graphics
  • unplugged all USB devices and external devices with the exception of the keyboard and mouse
  • Booted with system installation disc and attempted system repair several times only with the same outcome of wanting to restore from a previous system restoration point however it always fails
  • changed the boot type to IDE which made the system boot further past the logo screen however it still crashes with the same error
  • From the system installation disc I ran a chkdsk /f and no corruptions or bad sectors were found

However, I did run from the installation disc a "bcdedit" and my osdevice was unknown and my boot manager and boot loader were set to two different drives on being D: and the other being C:. So I relinked all three back to the D: drive as the windows installation disc says thats where Windows 7 is installed, although in the actual windows 7 My Computer its listed as C: drive which is weird? anyways after re-linking them using bcdedit /set {default} osdevice partition=D: and the other two commands my recovery partition disappeared which was listed as C:, and now I can only see my local drive? That did not fix the error, so I tried one last thing and ran another chkdsk D: /f /r which is taking for ages and I'm assuming my hard drive and its contents are still intact, because its taking so long and there are 612080 files to be processed!

I thought I might try and rebuild Master Boot Record?

I don't want to lose any of my data. Well I hope I haven't lost any because I have over 150+ games and their saves :(

Any help or suggestions would be much appreciated. :D

share|improve this question
    
Asking for help fast will probably mean most will take their time! We're not here to drop what we're doing to help you, I would consider editing your question and remove that line so your question doesn't read as rudely as it does now –  Dave Rook Mar 13 at 11:13

1 Answer 1

Using recovery CD/USB: (switch back to AHCI as it was before)

a) Start diskpart and examine partitions to see if active partition (where boot files are) is a separate partition.

Usually C: is mapped to active (System Reserved) partition when you boot from recovery media and D: is mapped to partition where Windows is installed.

If this is the case run following command to fix BCD:

bcdboot d:\windows /s c:

If you have only one partition (which should be active) then the fixing is done with:

bcdboot c:\windows /s c:

b) Reboot and using F8 key start safe mode.

If this is successful you can reinstall video driver and check system files(using sfc command).

If you cannot boot to safe mode then you can do 3 consecutive runs of "StartUp Repair" with rebooting after each run.

If StartUp Repair cannot fix booting then you have to try to fix safe mode with an offline system file check booted from recovery media (google for "sfc offline" for exact syntax of command).

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.