Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am having an issue mounting a logical drive to a folder on a RHEL VM. Below are the steps I took:

1. added a new drive to my computer (allocated more space to the VM)
2. created partition, sdb1, using 'fdisk /dev/sdb' and set to "linux LVM" (8e)
3. formatted sdb1 to ext3 with following cmd: mkfs.ext3 /dev/sdb1
4. added sdb1 to volume: vgextend /dev/sdb1
5. Created Logical volume: lvcreate -L 10G VolGroup00
6. Mounted: mount -t ext3 /dev/VolGroup00/lvol0 /test

the mount command gave me the following error:

mount: wrong fs type, bad option, bad superblock on /dev/VolGroup00/lvol0,
   missing codepage or other error
   In some cases useful info is found in syslog - try
   dmesg | tail  or so

When I run dmesg | tail I get:

VFS: Can't find ext3 filesystem on dev dm-2.

Is there something I did wrong? I dont know why it cant find the ext3 filesystem because I definitely created it. I have redone this twice now.

share|improve this question
1  
You seem to have forgot mke2fs -j /dev/VolGroup00/lvol0. –  Sami Laine Mar 14 at 15:35
    
thank you! That worked. One question: What is the difference between mke2fs and mkfs.ext3? when calling mkfs.ext3 it did not work. When calling mke2fs as you suggested, it worked. I did not specify the -j option on my mkfs.ext3 command because the man page says its already implied for mkfs.ext3 –  user972276 Mar 14 at 15:44
    
mkfs.ext3 and mke2fs -j produce identical results, EXT3 is basically EXT2 with journaling and -j just toggles the journaling on. –  Sami Laine Mar 14 at 17:00
    
yeah thats what I thought! I completely missed your point the first time around. I read your comment as mke2fs -j /dev/sdb1 instead of mke2fs -j /dev/VolGroup00/lvol0. I just copied and pasted your code and ran it and still missed that I needed to create the file system on the LV instead of the PV. I was racking my head trying to figure out the difference between what you suggested and what I did. Thanks for your help! –  user972276 Mar 14 at 18:34

1 Answer 1

up vote 0 down vote accepted

As Sami Laine pointed out, I had created the filesystem on the physical volume, but not the logical volume. Here is the command I forgot:

mke2fs -j /dev/VolGroup00/lvol0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.