Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Lubuntu as a virtual machine in virtual box. The problem I'm getting is trying to install guest additions.

When I run uname -r I get:

3.11.0-14-generic

This is my log for /var/lib/dkms/vboxguest/4.2.4/build/make.log:

DKMS make.log for vboxguest-4.2.4 for kernel 3.11.0-14-generic (i686)
Fri Mar 14 18:11:21 EDT 2014
make: Entering directory `/usr/src/linux-headers-3.11.0-14-generic'
make: Makefile: No such file or directory
make: *** No rule to make target `Makefile'. Stop.
make: Leaving directory `/usr/src/linux-headers-3.11.0-14-generic'

I get this whenever I'm trying to apt-get install 3.11.0-14-generic, I get that error in the make. This is my log for the apt-get:

Log started: 2014-03-14 18:11:10
Selecting previously unselected package linux-headers-3.11.0-14-generic.
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading d
Unpacking linux-headers-3.11.0-14-generic (from .../linux-headers-3.11.0-14-generic_3.11.0-14.21_i386.deb) ...
Setting up linux-headers-3.11.0-14-generic (3.11.0-14.21) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.11.0-14-generic /boot/vmlinuz-3.11.0-14-generic
ERROR (dkms apport): binary package for vboxguest: 4.2.4 not found
Error! Bad return status for module build on kernel: 3.11.0-14-generic (i686)
Consult /var/lib/dkms/vboxguest/4.2.4/build/make.log for more information.
Log ended: 2014-03-14 18:11:25

And for my vbox install this is my log:

Uninstalling modules from DKMS
Attempting to install using DKMS
Creating symlink /var/lib/dkms/vboxguest/4.2.4/source ->
/usr/src/vboxguest-4.2.4
DKMS: add completed.
Error! Your kernel headers for kernel 3.11.0-14-generic cannot be found.
Please install the linux-headers-3.11.0-14-generic package,
or use the --kernelsourcedir option to tell DKMS where it's located
Failed to install using DKMS, attempting to install without
Creating user for the Guest Additions.
Creating udev rule for the Guest Additions kernel module.
share|improve this question

3 Answers 3

Maybe the version of VirtualBox is too old for the guest. I have downloaded a fresh VBoxGuestAdditions.iso from VirtualBox:

http://download.virtualbox.org/virtualbox/4.3.8/VBoxGuestAdditions_4.3.8.iso

You can mount the newer iso and try again.

share|improve this answer
    
Encountered the same problem as OP too, after looking at the version number on your URL I just realized that I've mistakenly installed an old version of VirtualBox from 2012. Me = dumb. :) –  lurkless Oct 21 at 12:34

Try this:

$ sudo apt-get update

$ sudo apt-get install build-essential linux-headers-$(uname -r)

And then, try to install guest additions again.

share|improve this answer
    
I already did that. I tried inputting anyways and I got an error during the VBoxLinuxAdditions.run, here's the log: paste.ubuntu.com/7098021 –  user1766555 Mar 15 at 21:25

To update the kernel you can use:

sudo apt-get install linux-generic

If you need this particular version, it can be found here(linux-headers-3.11.0-14-generic).

It can be installed by running the command below:

sudo apt-get install linux-headers-3.11.0-14-generic

From the VirtualBox manual, Chapter 4 (Guest Additions), section Installing the Linux Guest Additions:

Ubuntu:

 sudo apt-get update
 sudo apt-get upgrade
 sudo apt-get install dkms

Reboot your guest system in order to activate the updates and then proceed as described above:

  • Insert the VBoxGuestAdditions.iso CD file into your Linux guest's virtual CD-ROM drive [Don't do this, if the Storage tab shows it to be already attached to the virtual machine]
  • Open a terminal, Change to the directory where your CD-ROM drive is mounted, and - execute as root: sh ./VBoxLinuxAdditions.run.
share|improve this answer
    
I already did that. –  user1766555 Mar 15 at 21:12
    
@user1766555 Look now. :) –  QMechanic73 Mar 15 at 21:19
    
Same errors and log when I run VBoxLinuxAdditions.run paste.ubuntu.com/7098021 Can't have virtual box automatically resize the resolution. –  user1766555 Mar 15 at 21:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.