Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Lately Windows 7 has been throwing these weird errors at me and refusing to open certain applications. From what I've managed to figure out, the problem might be a lost dll.

Errors:

While trying to open up "Screen resolution", "Personalize", from the desktop, it throws back an error with "Explorer.EXE" in the title saying "No such interface supported". All I can do is to agree with "Ok".

When programs such as Microsoft Visual studio tries to open up Explorer.exe to open a file it will fail due to unknown reasons. "The operation could not be completed".

Trying to open up certain windows ("Join a Personal Area Network" and "Show bluetooth devices") for Bluetooth activities, the window just won't open up, while others open up in an instance.

Several activities in the Control panel won't work either, such as "Uninstall program", "Adjust screen resolution" (wont work from here either :p)


I'm really clueless where to look or what to do right now, except for re-installing the whole thing, which I rather not spend my weekend doing. Help? :)

share|improve this question

5 Answers 5

up vote 2 down vote accepted
+100

Some ideas:

  1. Have you installed some product just before this started happening?
    If yes, it might be the cause of the problem. An uninstallation is the best way to verify.
  2. Try to boot in Safe mode (F8 during Windows startup). In this mode only Windows components are allowed to startup. If the problem disappears, then it's some installed product that's causing it. Download Autoruns, save a system restore point, and then use it to serially block products from starting with Windows, until you find the guilty one.
  3. Based on the premise that something went wrong with your own account that prevents you from executing some programs, the solution would be to create a new user profile and abandon your old one.
  4. Based on the premise that some dll went wrong, and if you have a real Windows installation DVD (meaning not just a restore one), you might try to do an upgrade installation. This would do an upgrade of your system to itself, meaning nothing, but will re-establish any wrong dlls.
  5. The last-ditch effort would be to re-install Windows. But wait with this until some more ideas for solutions come in from others on this forum.
share|improve this answer
    
1) I've installed various programs, can't remember which was which. I can't open up windows Uninstall-dialog, so I can't really figure it out. 2) Didn't work 3) I can't create new user accounts, since that dialog won't open up either. 4) I tried their "repair my computer"-thingy, it couldn't help me. 5) This will work but it's a bit of a hassle. –  Martin Nycander Nov 22 '09 at 19:46
    
1) Try to use Revo Uninstaller : revouninstaller.com. 2) Then this is a problem with Windows itself. 3) See this : technibble.com/an-easy-way-to-brea-into-a-windows-user-account. 4) I meant Upgrade as in sevenforums.com/attachments/tutorials/…. –  harrymc Nov 22 '09 at 20:03
    
I'm doing a full virus scan at the moment, I will try an upgrade tomorrow. Thanks for the help btw :) –  Martin Nycander Nov 22 '09 at 20:31
    
Note: Your answer (2) invalidates the need for (1). We should now concentrate on (3) and (4). –  harrymc Nov 22 '09 at 20:32
    
An upgrade install solved the problem :) –  Martin Nycander Nov 27 '09 at 21:15

Not virus it is permissions problem you need to go into registry and correct the permissions for hkeyclasses root . Add the current user to the permissions of CLSID and give at least read access. For correct instructions go search for no such interface supported on sevenforums.com

share|improve this answer

I would personally see if a system restore works, and failing that, do a re install of Windows.

This is not the sort of error that happens every day, it must of been caused by some sort of failure and even though there are methods that may be able to fix it, if you do not know what caused it - it could lead to problems later on.

share|improve this answer
    
I've been dragging my feet with this problem, and as I recall it started to occur 3-4 weeks ago.. my system restore points apparently doesn't go that far back. –  Martin Nycander Nov 22 '09 at 19:48

there is a corrupted or missing system file, so SFC /SCANNOW may help you recover them.

share|improve this answer

We have had two such issues. Same exact problem. Doing a system restore back to a time before the problem existed fixed the problem. It seems a Microsoft update caused the issues.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.