Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm just trying a watch a commercially bought DVD on my laptop, but Ubuntu 12.04 won't recognise UDF:

$ sudo mount -t udf /dev/cdrom /media/cdrom
mount: unknown filesystem type 'udf'

I got the same message (more or less) from a dialog that popped up after putting the disk in. My understanding is that support for UDF should be built in. I know there's lots of questions regarding similar issues around, but the solutions all seem to suppose that Ubuntu knows what UDF is. Ubuntu is up to date, and I've rebooted very recently. Thanks.

Edit:

$ sudo dpkg --list | grep libdvd
ii  libdvdnav4  4.2.0-1ubuntu0.1  DVD navigation library
ii  libdvdread4  4.2.0-1ubuntu4  library for reading DVDs

libdvdcss doesn't seem to be available for download, but maybe that package isn't necessary any more??

share|improve this question
    
did you try "sudo mount /dev/cdrom /media/cdrom" without the -udf ? –  chaput Mar 17 at 18:08
    
I don't get why you might want to mount it just to watch it… what about (for example) vlc dvd:///dev/dvd (with libdvdcss installed)? –  Andreas Wiese Mar 17 at 18:26
    
@chaput that produces the same error –  RTF Mar 17 at 23:05
    
@AndreasWiese that did work, after I installed libdvdcss2, thanks (although I eventually jumped into Windows to watch the movie :o). But I'm still concerned that mount doesn't know what UDF is. I believe there's some option related to UDF when compiling the kernel, but if a re-compile is what's required, that seems a bit drastic. –  RTF Mar 17 at 23:11
    
That's definitely true: you need to set CONFIG_UDF_FS=y (or …=m) for UDF support in kernel configuration. That's overkill in any case if you just want to watch DVD movies. Even if you want to rip such disk I think installing dvdbackup and issueing dvdbackup -M -i /dev/dvd -o /path/to/backup and a subsequent mkisofs -o /path/to/target.iso -dvd-video -iso-level 3 -udf /path/to/backup should be enough to generate an UDF ISO image. –  Andreas Wiese Mar 17 at 23:51

1 Answer 1

The following:

cat /boot/config-`uname -r` | grep -i udf
# CONFIG_UDF_FS is not set

...showed that my kernel was not compiled with support for UDF, so that almost certainly explains the problem. I haven't recompiled so I can't verify this, but if you're suffering the same problem and just want to watch video content on a UDF disc, see the comments above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.