Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On the virtual machine, my netstat is:

$ netstat -a | egrep 'Proto|LISTEN'
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0 localhost:6379          *:*                     LISTEN
tcp        0      0 *:6767                  *:*                     LISTEN
tcp        0      0 *:sunrpc                *:*                     LISTEN
tcp        0      0 *:ssh                   *:*                     LISTEN
tcp        0      0 *:35478                 *:*                     LISTEN
tcp        0      0 localhost:postgresql    *:*                     LISTEN
tcp        0      0 *:8000                  *:*                     LISTEN
tcp6       0      0 [::]:sunrpc             [::]:*                  LISTEN
tcp6       0      0 [::]:45424              [::]:*                  LISTEN
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN

When I try to connect from my host machine, I get:

$ redis-cli -h 192.168.33.10 -p 6379
Could not connect to Redis at 192.168.33.10:6379: Connection refused

Not sure what else to do. Any ideas?

Thanks!

share|improve this question
    
Maybe this is obvious, but I'll ask it anyway: Can the host machine see the guest - 192.168.33.10 - at all? What are the machine OS'es? Is the firewall on that machine turned off? (iptables) Is the firewall on your host machine turned off? How are they connecting, e.g. host-only networking etc.? – Joshua Mar 17 '14 at 17:51
up vote 6 down vote accepted

the service is listening on 127.0.0.1

tcp        0      0 localhost:6379          *:*                     LISTEN
share|improve this answer
    
Why is this? In my redis.conf, I commented out the bind line so I should be listening on all interfaces, no? – Shamoon Mar 17 '14 at 17:56
    
did you restart the service ? – chaput Mar 17 '14 at 17:58
    
Yuppers. I most certainly did. – Shamoon Mar 17 '14 at 18:08
1  
maybe try to force to listen on the nic "bind 192.168.33.10" or this "bind 0.0.0.0" – chaput Mar 17 '14 at 18:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .