Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use mac osx terminal a lot. Whenever I want to print something more than one page onto the terminal screen, the screen stops scrolling after printing exactly one page, and shows "--More--" at the bottom of the screen to let me press "enter" to continue printing more lines, one line at a press.

What I want is the terminal screen auto scrolling to bottom of the outputs. Does anyone know how to make it?

Thank you guys for the replies. Let me illustrate with an example. After I double press tab button in my home directory, it doesn't show all the possibility of commands, which it should do, but displays a "--More--" at the bottom of the screen.

share|improve this question
    
So. This command that you run, whenever you want to print something. Is it the more command, by any chance? –  JdeBP Mar 17 '14 at 23:43
    
It doesn't seem that "more" command is what I want. I added a example in my original post. Btw, it shows "HELP -- Press RETURN for more, or q when done" at the bottle after I type "more --help". –  Aickson Mar 24 '14 at 5:31

2 Answers 2

Without an example, I have to imagine you're using some utility to display the file. If you simply cat the file, it will show the entire contents of the file to console. Then you're only limited by the amount of scrollback in your terminal window.

(BTW, you can change the scrollback buffer to unlimited in Terminal -> Preferences)

HTH

share|improve this answer
    
Yes, cat can show all the file. My problem is now specified in my origin post. Can we do anything about it? –  Aickson Mar 24 '14 at 5:38
    
Ah, I see what you're talking about now. I was unaware of this functionality. But to get what you're asking for, try compgen -ca from the command line and you'll get all commands in a single column format. GL. –  SaxDaddy Mar 25 '14 at 0:15
    
Thank you for the tips. Best –  Aickson Mar 25 '14 at 5:08

The pager that displays --More-- is shown by readline, and it shouldn't be shown for all output but just for things like possible completions.

To remove it, add this line to ~/.inputrc:

set page-completions off

To also remove the Display all ... possibilities? (y or n) prompt, add:

set completion-query-items 0
share|improve this answer
    
Thank you. Both commands work. –  Aickson Mar 24 '14 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.