Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Acer p243-m which came with Windows 7. The USB 3.0 port worked fine after installing the driver.

But after I clean installed Windows 8, the speed dropped from say 100MBps to 28MBps.

How would I go about finding the cause of this in order to improve my transfer speed?

share|improve this question
Check Device Manager - do you have the proper drivers for the USB controller? If not, check Acer's support website for your particular model and see if they have any drivers you need to install . . . – ernie Mar 18 '14 at 16:27
What storage device are we talking about? What are you doing with it? Also, please use proper units. It's either Megabytes/second or Megabits/second. – Daniel B Mar 18 '14 at 16:29
Have you done all the Windows Updates? Sometimes Windows has the latest updates in their repositories but sometimes not so much. You will have to figure out the specific controller brand which is soldered to your motherboard an download the proper drivers from their website for the best performance. If they do not officially support Windows 8 or greater then you will have to wait for the release of proper drivers. – MonkeyZeus Mar 18 '14 at 16:44
Do you have 32-bit or 64-bit Windows 8? – MonkeyZeus Mar 18 '14 at 16:48
Looks like Acer does not list any USB 3.0 drivers on their website. but Intel appears to be the manufacturer so check out Intel's site for the latest drivers. – MonkeyZeus Mar 18 '14 at 16:51

2 Answers 2

Try turning off suspend USB Power Saving Feature and ensure you have updated drivers. This fixed the problem for me, i went from 60MB/s to 170MB/s


enter image description here

share|improve this answer

I had the same problem and tried upgrading the firmware and also tried different Windows drivers without luck. I kept trying different things and found the problem, my USB3.0 doesn't drive enough power, If I use an (external) Y-cable to plug the device then it works well. (with data plugged to USB3 and power to a USB2 of a different controller).

I knew that was needed for some devices that need a lot of power but my NEC/Renesas USB3.0 needs it even for a pendrive, kinda ridiculous.

That way it works faster than USB2.0 but anyway is not a good controller.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.