Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set up postfix + dovecot and know that I want to have mailing lists I decided to install mailman.

Everything is working except that I cannot send emails to my mailing list (and this is quite important, don't you think?).

When I'm sending a mail to my mailing list (test@too.gy), I get a reply 'Undelivered Mail Returned to Sender' saying:

This is the mail system at host too.gy.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<test@too.gy>: unknown user: "test@too.gy"

It seems like postfix is trying to authenticate my mailing list address, which, obviously, is not registered in postfix user database.

But I followed the instructions during the installation and I don't why it's happening. I went through all the mailing lists I found discussing this question and it's still not working. So here I am.

Here is my postconf -n output:

alias_database = $alias_maps
alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/bin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5
html_directory = no
inet_protocols = ipv4
local_recipient_maps = $virtual_mailbox_maps $alias_maps
local_transport = virtual
mail_owner = postfix
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
mydestination = localhost, too.gy
mydomain = too.gy
myhostname = too.gy
mynetworks_style = host
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix
recipient_delimiter = +
relay_domains = *
sample_directory = /etc/postfix/sample
sendmail_path = /usr/bin/sendmail
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_relay_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $mydomain
smtpd_sasl_path = /var/run/dovecot/auth-client
smtpd_sasl_security_options = noanonymous
smtpd_sasl_tls_security_options = $smtpd_sasl_security_options
smtpd_sasl_type = dovecot
smtpd_tls_auth_only = yes
smtpd_tls_cert_file = /etc/ssl/private/server.crt
smtpd_tls_key_file = /etc/ssl/private/server.key
smtpd_tls_loglevel = 1
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550
virtual_alias_maps = proxy:mysql:/etc/postfix/virtual_alias_maps.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_gid_maps = static:5000
virtual_mailbox_base = /home/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/virtual_domains_maps.cf
virtual_mailbox_limit = 512000000
virtual_mailbox_maps = proxy:mysql:/etc/postfix/virtual_mailbox_maps.cf
virtual_minimum_uid = 5000
virtual_transport = virtual
virtual_uid_maps = static:5000

And my /etc/mailman/mm_cfg.py:

# -*- python -*-

###############################################
# Here's where we get the distributed defaults.

from Defaults import *

##################################################
# Put YOUR site-specific settings below this line.

DEFAULT_URL_HOST = 'lists.too.gy'
DEFAULT_EMAIL_HOST = 'too.gy'
MTA = 'Postfix'

VIRTUAL_HOSTS.clear()
add_virtualhost(DEFAULT_URL_HOST, DEFAULT_EMAIL_HOST)

POSTFIX_STYLE_VIRTUAL_DOMAINS = ['too.gy']

DEFAULT_URL_PATTERN = 'http://%s/'
PUBLIC_ARCHIVE_URL = 'http://%(hostname)s/archives/%(listname)s'

MAILMAN_SITE_LIST = 'mailman'

FULL POSTFIX LOGS:

Mar 20 09:38:27 ks3100290 postfix/postfix-script[18843]: starting the Postfix mail system
Mar 20 09:38:28 ks3100290 postfix/master[18845]: daemon started -- version 2.11.0, configuration /etc/postfix
Mar 20 09:38:57 ks3100290 postfix/smtpd[18849]: connect from mail-pa0-f45.google.com[209.85.220.45]
Mar 20 09:38:57 ks3100290 postfix/trivial-rewrite[18853]: warning: do not list domain too.gy in BOTH mydestination and virtual_mailbox_domains
Mar 20 09:38:57 ks3100290 postfix/smtpd[18849]: 8829A2041F: client=mail-pa0-f45.google.com[209.85.220.45]
Mar 20 09:38:57 ks3100290 postfix/cleanup[18857]: 8829A2041F: message-id=<532AA8DC.8090203@gmail.com>
Mar 20 09:38:57 ks3100290 postfix/qmgr[18847]: 8829A2041F: from=<tout.guy@gmail.com>, size=1768, nrcpt=1 (queue active)
Mar 20 09:38:57 ks3100290 postfix/trivial-rewrite[18853]: warning: do not list domain too.gy in BOTH mydestination and virtual_mailbox_domains
Mar 20 09:38:57 ks3100290 postfix/virtual[18858]: 8829A2041F: to=<test@too.gy>, relay=virtual, delay=0.57, delays=0.48/0.02/0/0.06, dsn=5.1.1, status=bounced (unknown user: "test@too.gy")
Mar 20 09:38:57 ks3100290 postfix/cleanup[18857]: E9EC6207B8: message-id=<20140320083857.E9EC6207B8@too.gy>
Mar 20 09:38:57 ks3100290 postfix/bounce[18861]: 8829A2041F: sender non-delivery notification: E9EC6207B8
Mar 20 09:38:57 ks3100290 postfix/qmgr[18847]: E9EC6207B8: from=<>, size=3443, nrcpt=1 (queue active)
Mar 20 09:38:57 ks3100290 postfix/qmgr[18847]: 8829A2041F: removed
Mar 20 09:38:58 ks3100290 postfix/smtpd[18849]: disconnect from mail-pa0-f45.google.com[209.85.220.45]
Mar 20 09:39:08 ks3100290 postfix/smtpd[18849]: warning: hostname user.mvnet.at does not resolve to address 85.255.155.158
Mar 20 09:39:08 ks3100290 postfix/smtpd[18849]: connect from unknown[85.255.155.158]
Mar 20 09:39:08 ks3100290 postfix/trivial-rewrite[18853]: warning: do not list domain tOo.gY in BOTH mydestination and virtual_mailbox_domains
Mar 20 09:39:08 ks3100290 postfix/smtpd[18849]: NOQUEUE: reject: RCPT from unknown[85.255.155.158]: 550 5.1.1 <EzRK0Vzs47@tOo.gY>: Recipient address rejected: User unknown in local recipient table; from=<EzRK0Vzs47@user.mvnet.at> to=<EzRK0Vzs47@tOo.gY> proto=ESMTP helo=<user.mvnet.at>
Mar 20 09:39:08 ks3100290 postfix/smtpd[18849]: disconnect from unknown[85.255.155.158]
Mar 20 09:39:28 ks3100290 postfix/smtp[18862]: E9EC6207B8: to=<tout.guy@gmail.com>, relay=gmail-smtp-in.l.google.com[173.194.67.27]:25, delay=31, delays=0.03/0.02/30/0.57, dsn=2.0.0, status=sent (250 2.0.0 OK 1395304718 ba4si773777wjc.22 - gsmtp)
Mar 20 09:39:28 ks3100290 postfix/qmgr[18847]: E9EC6207B8: removed
share|improve this question
add comment

1 Answer 1

You included mailman aliases properly under alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases. But you have overwritten your local_recipient_maps. Just modify your local_recipient_maps as following in your main.cf, Because local recipients will be searched in local_recipient_maps.

local_recipient_maps = $virtual_mailbox_maps $alias_maps
share|improve this answer
    
Hey, thanks for the reply. I did exactly what you said, restarted postfix but I still have the same problem. :/ –  toogy Mar 19 at 20:04
    
Can u paste the log lines generated by postfix? –  clement Mar 20 at 7:46
    
I added the log lines. Also put the result of postconf -n. Thanks for the help. –  toogy Mar 20 at 8:43
    
See too.gy is listed under mydestination and virtual_mailbox_domains too. Fix that first. Remove too.gy from virtual_mailbox_domains. So postmap -q too.gy mysql:/etc/postfix/virtual_domains_maps.cf shouldn't return any output. –  clement Mar 20 at 10:23
    
I followed the instructions on ArchWiki: wiki.archlinux.org/index.php/…. It looks like that postmap -q too.gy mysql:/etc/postfix/virtual_domains_maps.cf should return my domains, as for them :/ And I fixed it by putting mydestination = localhost. I don't have the warning but it's still not working. Mails from anywhere to my addresses created using postfix admin are working though. It's only with mailman that it's not working. –  toogy Mar 20 at 11:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.