Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the log of the squid proxy cache server me and some warnings are coming out every time I leave the proxy fails to resolve normally, it starts to take to resolve.

WARNING: no_suid: setuid(0): (1) Operation not permitted

I solve the above problem by restarting the squid proxy server, but after a while the same thing happens to me.

I was looking at the logs and I see other warnings but nothing abnormal.

UPDATED:

My OS is Ubuntu 12.04 Server 64bit and Squid 3.4.4.

Parameters to compiler:

./configure '--build=x86_64-linux-gnu' '--prefix=/usr' '--includedir=${prefix}/include' 
'--mandir=${prefix}/share/man' '--infodir=${prefix}/share/info' '--sysconfdir=/etc' 
'--localstatedir=/var' --enable-err-languages='English Spanish' '--enable-default-
err-language=Spanish' '--libexecdir=${prefix}/lib/squid' '--srcdir=.' '--disable-
maintainer-mode' '--disable-dependency-tracking' '--disable-silent-rules' '--datadir=/usr
/share/squid' '--sysconfdir=/etc/squid' '--mandir=/usr/share/man' '--enable-inline' 
'--enable-async-io=8' '--enable-storeio=ufs,aufs,diskd' '--enable-removal-
policies=lru,heap' '--enable-delay-pools' '--enable-cache-digests' '--enable-underscores' 
'--enable-icap-client' '--enable-follow-x-forwarded-for' --enable-auth '--enable-basic-
auth-helpers=LDAP,MSNT,NCSA,PAM,SASL,SMB,YP,DB,POP3,getpwnam,squid_radius_auth,multi-
domain-NTLM' '--enable-digest-auth-helpers=ldap,password' '--enable-negotiate-
auth-helpers=squid_kerb_auth' --enable-arp-acl --enable-esi '--enable-zph-qos' '--enable-
wccpv2' '--disable-translation' '--with-logdir=/var/log/squid' '--with-pidfile=/var
/run/squid.pid' '--with-filedescriptors=65536' '--with-large-files' '--with-default-
user=proxy' '--enable-linux-netfilter' 'build_alias=x86_64-linux-gnu' 'CFLAGS=-g -O2 -fPIE 
-fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security -Werror=format-
security' 'LDFLAGS=-Wl,-Bsymbolic-functions -fPIE -pie -Wl,-z,relro -Wl,-z,now' 
'CPPFLAGS=-D_FORTIFY_SOURCE=2' 'CXXFLAGS=-g -O2 -fPIE -fstack-protector --param=ssp-buffer-
size=4 -Wformat -Wformat-security -Werror=format-security'  'build_alias=x86_64-linux-gnu' 
--with-squid=/build/buildd/squid3-3.4.4

And add user proxy:

sudo adduser --system proxy

The squid server proxy normally rises and can navigate, I spent a few minutes or hours, starts to get slow and I always get the above error.

My idea of ​​putting problem is the problem of cache with user privileges on the proxy.

Thanks in advances.

share|improve this question
1  
What OS, what user are you running squid under. Give more details. It is a permissions problem of some source, so track that down. –  Zoredache Mar 19 at 21:28
    
I'm updated the ask. –  josecarlos Mar 24 at 3:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.