Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been experimenting with uxrvt recently as a potential replacement for gnome-terminal. One problem I'm having with it is inserting continuation characters when a line wraps around. This is a problem with long URL's (e.g. password reset keys) as the URL is broken up and an extra character included.

How can I disable this behaviour?

share|improve this question
    
Is TERM set to TERM=rxvt-unicode ? What window manager are you using - gnome? i know xmonad has a crlf off option specifically related to copying from the terminal, but not sure if this is what's driving your problem or if there is a related fix in whatever WM you're using. – DaveParillo Nov 20 '09 at 16:44
    
TERM is set to "screen" as I'm running a screen session inside. However without entering a screen session TERM=rxvt-unicode I get the same effect. I'm running under Gnome, but using urxvt as it handles UTF-8 better than gnome-terminal does. – stsquad Nov 25 '09 at 14:30
up vote 1 down vote accepted

Doesn't do this for me.

echo -n abc def ghi jkl mno pqr stu vwx yza bcd efg hji; echo -n abc def ghi jkl mno pqr stu vwx yza bcd efg hji; echo abc def ghi jkl mno pqr stu vwx yza bcd efg hji

results in just simple wrapped output, with no "+". I checked my ~/.config/app-defaults/URxvt to see if I had given any special setting for this, but nothing looks relevant. And moving that aside and starting a new terminal gives me same behavior.

I do see + at the start of wrapped lines in vim. Similarly, a "@" at the end of wrapped lines in less. But I assume you're just talking about wrapped lines at the shell prompt.

Do you still see this is you temporarily move aside all your .bashrc-and-friends files and start a new terminal?

share|improve this answer
    
Your right, that doesn't trigger it. I suspect I've blamed the wrong program as it's something I only really see with long URLs in my mail client. – stsquad Feb 16 '10 at 8:33
    
Then if it's fixable it's probably a setting on your mail client or the pager it uses. If you're using mutt, I recommend you check out urlview. Once it's installed and you add a mutt keybinding for it, when you're looking a message you hit a key and see a list of all the urls in the mesage. Choose one, and it'll start in the browser you've specified. – dubiousjim Feb 16 '10 at 11:58

Are you sure it's urxvt that's adding the "+" signs? I'm taking a wild guess here, and gonna assume you use mutt (because I use urxvt and had that issue with mutt).

Add set markers = no to your muttrc.

share|improve this answer
1  
Blast from the past ;-) - yep I had added the change to muttrc in Nov 2010. – stsquad Jul 21 '14 at 10:03
1  
I'm glad you haven't been suffering from this for four years. I left this answer in great part for posterity's sake, since this result comes up pretty easily. – Hugo Jul 23 '14 at 20:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .