Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a Dell XPS-8700 tower running Windows 8.1 Pro. I've had this PC for a couple of months, and installed two additional SATA drives from my old system. The boot drive is a 1Tb Western Digital that came with the system, the second is a Maxtor 300Gb and the third is a 2Tb Hitachi. The additional drives are for data only, I'm not dual-booting this system with anything else.

Things had been just fine until the other day, when I attached an external SATA drive using one of the USB ports, and the drive was already formatted and had drive letter E: assigned to it. Well, that conflicted with one of the internal drives (drive #3). The USB drive took priority, as it's the one that was visible in the Windows Disk Management utility and File Explorer.

I changed the USB's drive letter to G:, ejected the USB drive and rebooted the system, thinking that would bring back the internal drive that had been assigned as E:, but it no longer appeared in either the File Explorer or Disk Management utility. I rebooted into the BIOS, and the disk was there, so I tried booting into Windows again, with no luck. The drive was not visible at all.

So I swapped cables with drive #2, and now drive #3 appeared and drive #2 was no longer visible. Of course, now drive #3 was assigned letter D:. So I swapped SATA cables back and tried attaching drive #3's cable to an unused port on the motherboard. Rebooted and no luck, however drive #2 was back as letter D:.

Frustrated at this point, I began swapping things around hoping to find some combination of cables and ports that would make all the drives appear, with no luck. Even worse, now NEITHER of drive #2 or #3 appear at all! The boot disk, which I haven't touched, still appears as drive C:, and the DVD-RW drive appears no matter which cable I use or which SATA port I attach it to on the motherboard.

I read somewhere about a new type of mechanism called UEFI, and there is something about that displayed when I boot into the BIOS. And all of the drives ALWAYS appear in the BIOS no matter how I've swapped them or rearranged the cables.

What is going on??? Did I just totally hose my drives? Guess I'll plug them into an external case to see if they can still be recognized over USB.

Oh, the last thing I tried was disconnecting drive #3 from power/SATA and rebooting to see if drive #2 would appear. It did not. However I thought I heard what sounded like a drive spinning down just after booting. I'm wondering if something is telling the drives to power down for some reason, before Windows can see them.

In the mean time, any tips would be appreciated.

UPDATE:

I took drive #3 out of the system and confirmed that it works just fine when placed in an external case attached via USB. The data is still there.

share|improve this question
    
Did you ever figure this out? I installed a second SATA HDD from my old laptop into my new one hoping I could use it like a media drive and it's not recognized anywhere but in the BIOS. Very puzzling. –  Maurice Reeves Jun 20 at 19:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.