Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have previously asked for help with this on the "Unix and Linux" site as the question "Linux Fedora 20: how do I deal with “ import read failed(2)”?" (I got there after a lot of floundering about). Although several kind people suggested things to try, none of them solved the problem. Details are in that question so I will not repeat them here, but I am now convinced that there is a deeper underlying fault that needs correction.

I had installed Fedora 20 on a new PC, put together for me by a local vendor, who installed Windows XP3 for me and left a big partition for Linux. All went well, with a dual boot ok, until I tried to install emacs with yum install emacs (after su of course.) I got a stream of error messages, all ending with ... [Error 14] curl#6 - "could not resolve host: mirror ...", and the same thing happened for gcc and whatever else I tried to install

With no idea what this meant I posted several questions, and searched the 'net, but none of the proffered solutions worked. In the end I tried installing openSUSE instead, but got a very similar result with zypper install emacs. I went back to Fedora 20 again.

So the fault was not specific to the distro. Today I ran jounalctl and got this, which may be the clue: Failed to open private bus connection: Failed to connect to socket /run/user/1000/dbus/user_bus_socket:.

Also, the internet connection works perfectly for browsing, email etc in both Windows and Linux F20 on this dual boot machine, with a wired connection to a BT Homehub 3 Router, and on two Windows laptops with wireless connections.

I have no experience with or knowledge of the system at this level, so, please, can anyone help me -- I have now spent four desperate weeks struggling with it.


Thanks andrej for your comment "seems like proxy for browsing but not for curl/wget usage." That sounds good to a non-expert, but I don't know how to deal with it, please could you or someone expand the explanation, and give the details to help me to proceed?

share|improve this question
    
seems like proxy for browsing but not for curl/wget usage. –  andrej Mar 21 at 13:45
    
While yum is struggling/stalled, can you load new webpages in your browser? –  rickhg12hs Mar 23 at 3:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.