Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As a developer I work with a lot of source code files etc. and I need to copy these around, rename, etc. I'm sure any developer knows the drill.

Windows Explorer is really "helpful" in suggesting different Views for different folders. Apparently one source code folder is an image folder, another apparently needs large icons etc. This appears to be getting worse with every new Windows release. It used to be possible to set a View on a root folder and Windows would pretty much respect that, but Vista keeps guessing (wrong) no matter what I do.

I like many of the other improvements that MS made to Windows Explorer over the years, but this persistent attempt and failure to guess how I want my files listed make it counterproductive and really spoils it all.

So I gave up on Windows Explorer and now use Salamander instead. But the problem comes up again every time I use someone else's computer, and whenever a program uses the standard file open/save dialogs.

Please - does anyone know of a way to tell Windows Explorer to always use Detail View - and keep doing it?

Thanks in advance

share|improve this question

migrated from stackoverflow.com Mar 21 at 12:34

This question came from our site for professional and enthusiast programmers.

"how is this a programming question?" He's trying to make his development environment more programmer-friendly? Not everything about programming is code, code, code. Though, if you take this too far, you end up debating the best deodorant to make your co-workers not fear talking to you, so I guess you do have to draw the line somewhere. But I think a lot of SO users make things a tad too strict. –  bsneeze May 4 '09 at 4:44
add comment

3 Answers

up vote 14 down vote accepted

Found the fix here:

Copy the text between the lines below into notepad & save as a .reg file. Watch out for line wrap -- [HKEY_CURRENT_USER...\Shell] is all one line.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags\AllFolders\Shell]

Merging the .reg file will set the 'All Items' template for any folders that don't currently have a view saved with a different template. You can clear all saved views by deleting the

"HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\Bags"

key BEFORE merging the .reg file. If any folders open with a different template after clearing the 'Bags' key & merging the .reg file, they most likely have a template specified via their desktop.ini file.

-- Good Luck,

Keith Microsoft MVP [Windows XP Shell/User]

share|improve this answer
add comment

Set the folder you're in to detail view, go to Tools > Folder Options, click the View tab, and click Apply to All Folders

share|improve this answer
If you're on Vista or 7, the menu bar might be hidden. Just press the Alt key to show it. –  bsneeze May 3 '09 at 23:19
No such function in Vista –  Jesper May 3 '09 at 23:19
On Vista and Windows 7 you'll find it in Organize > Folder and Search options > View > Apply to Folders. –  Јοеу May 3 '09 at 23:25
@Jesper: it's still there in Vista, but it's hidden. The non-hidden route, I guess, is what Johannes pointed out. –  bsneeze May 3 '09 at 23:28
Nope - there is no "Apply to all folders" function there either. There is a "Apply to folders" button - but that is very different - that only sets the columns etc. for a specific view. Vista will still guess (wrong) what type of folder each folder is - and thus the associated View. –  Jesper May 3 '09 at 23:31
show 1 more comment

Apparently Windows (Vista, as well as XP) likes to reset the view settings of folders on its own, so you have to install 3rd party software to actually get it to remember the view settings for each folder.

Supposedly XdN Tweaker's "Make Views Stick" function in the "Files & Folders III" dialog (truly horrendous interface design) will make your folder view settings actually stick. So then you just need set one folder to "Details" view, check "Enable Each Folder's View Settings", and then "Apply to All Folders."

share|improve this answer
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.