Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an embedded Ubuntu 12.04 system running with no monitor and I need to run a command in the terminal. I can connect a USB keyboard (or even a mouse, but a mouse would be difficult to use without a monitor) and log into the Ubuntu desktop. How can I bring up the terminal using only the keyboard without any visual feedback?

share|improve this question
3  
ALT + F2 and typing gnome-terminal ready. – Jose Carlos Ramos Carmenates Mar 22 '14 at 12:13
3  
Why are you operating in the dark like that? Can you not access this system via SSH? – I-Ii Mar 22 '14 at 21:12
    
@Jason If I could have, I would have. In fact connecting to wifi is exactly what I was going to do with the terminal. – Matt Mar 29 '14 at 22:05
1  
@Matt been there before. Without any output though, I foresee a frustrating experience. Some alternatives to trying to configure your machine without any feedback: you could remove the hard drive and configure the wifi and ssh then replace it, or install an os on a flash drive with ssh and wifi set up then access the machine via this os with ssh and write the configurations to the internal hdd. – I-Ii Mar 31 '14 at 2:25
up vote 22 down vote accepted

Just hit Ctrl+Alt+F1 to switch to another tty. That's probably easiest.

share|improve this answer
3  
I sometimes have problems with tty1. Ctrl+Alt+F2 works each time. – gronostaj Mar 21 '14 at 17:16
    
Thanks! Does this work from the login screen as well? – Matt Mar 21 '14 at 17:17
2  
@Matt Yes. You'll probably have to log in on the other tty as well though. – Oliver Salzburg Mar 21 '14 at 17:17
    
Yes I realize that (mostly because I just tried it out on another Ubuntu I'm on right now). – Matt Mar 21 '14 at 17:19
    
I think this does not prevent GUI opening in other TTYs. I meshed up my GPU settings so do not want to start it in GUI. Does this prevent GUI opening in other TTYs? The system seems to start GUI also in other TTY simultaneously. – Masi Jan 2 at 10:28

For Unity (shipped by default since the Ubuntu12), Gnome, LXDE, Cinnamon and MATE, the Ctrl+Alt+T keyboard shortcut will work if you are already logged in.

If you are using Xfce (Xubuntu), however, it would be Super+T. (Note that Super is the Windows key)

And as far as I am aware, in KDE, while it is also Ctrl+Alt+T, for some reason, there are issues with the default shortcuts. So you have a few other options. Press Alt+F2, then type konsole and press Enter. If you have full access to the system, and you want to set up a keyboard shortcut, right click on the Menu, find Konsole, select Advanced tab, Current shortcut key. Select a combination of your liking, though be careful with shortcuts already in use.

As per Terdon's request, this answer has been expanded to provide information about the different Ubuntu environments.

share|improve this answer
    
This is a great answer and will probably come in hand, but unfortunately in this situation Oliver's answer is better. – Matt Mar 21 '14 at 17:23
1  
It is good when issues are resolved quickly. Cheers! – Kard Nails Mar 21 '14 at 17:40

If you still have access to it, ALT + F2 is essentially a one-time run dialog. It can be re-enabled in System > Preferences > Keyboard Shortcuts.

This used to be a standard short cut. Why Canonical removed it, I'll never know.

http://help.ubuntu.com/community/KeyboardShortcuts

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .