Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just did a huge full-upgrade (been a while since the last so a lot of stuff changed) and also upgraded to kernel 2.6.30.
After this I'm having some annoyances with the touchpad: the worst thing is that I can't turn it of anymore. I used to do it with a simple

synclient TouchpadOff=1

then with xinput as per this message, but then I had to tweak psmouse module as suggested in the SynapticsTouchpad Debian Wiki because the tap-click wasn't working anymore. After that I can't disable that stupid device by no means: no synclient, no xinput, no gsynaptics.

I also dislike the new pointer speed and can't tweak that either, but that's a minor annoyance since I use the touchpad only when I can't use the mouse (and the reason I want to turn it off is that I keep hitting it with my thumbs while typing).

share|improve this question

2 Answers 2

up vote 2 down vote accepted

In lieu of fully disabling the touchpad, you could try touchfreeze, which should disable the touchpad only while you are typing. I've never tried it on Debian, but I have used it on Ubuntu it worked fairly well.

share|improve this answer

Oh well, my mistake was trying to be too specific:

# modprobe -r psmouse

took care of the damn thing for good.

share|improve this answer
1  
+1 for a non "apt-get that and your problem will be solved" solution. –  Hello World May 19 at 15:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.