Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For years I've been using a script to copy files from the Memory Stick of my camera. Simple file transfer, no problems at all.

Today, all I can see in Explorer is two files: MEMSTICK.IND and MSTK_PRO.IND. Same thing whether I connect the camera with the USB cable or pull the stick out and put it in the card reader on my computer.

The only other symptom is that the drive letter where the stick appears also changed (but it's still called CAMERA, so the computer seems to recognise that it's seen it before).

(It's a Sony DSC-W30, and the camera itself can see plenty of photos)

Vista Home 32bit, French.

Update: tried on work PC (which has never seen this card before) and it works ok. So it's a PC problem, not a camera/memorystick problem, apparently.

Update2: fresh install of Win7 on the same PC (different disk) presents the same problem.

share|improve this question
I suggest you search this site for 'USB recovery', there have been plenty of people with similar issues. Before undertaking actual action with any recovery, try to make a 'disk' copy of the USB. Read enough posts to get familiar with how these kinds of recovery are done, before actually running recovery software, because the software makes irreversible changes. – Jan Doggen Mar 23 '14 at 16:58
@JanDoggen, even though the camera can read it ok? – Benjol Mar 23 '14 at 17:01
What operating system (distribution, version) do you have on the PC? Does the USB port work with other devices? If the USB drive shows up somewhere else, are you sure you are looking at the right one? Any other USB devices connected? – vonbrand Mar 23 '14 at 17:13
@vonbrand, updated question. Nothing else connected at the moment. – Benjol Mar 23 '14 at 17:19

1 Answer 1

OK, I've worked out what the problem was, and how to solve it, but I'm not at all sure how it happened.

I noticed on my work PC that the visible DCIM folders were 'grayed out' - i.e. marked as hidden system files. (It just happened that on my home PC I didn't have explorer set to show hidden files).

The folder properties dialogue wouldn't let me uncheck the hidden option, so I ended up transferring the photos off, and then using the camera 'format' function.

After which, everything works again on my home PC.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.