Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Windows can't connect to the WLAN network every time I turn on Windows, so I need to restart my router manually, which is very annoying.

When I tried to ask Windows for help resolving this, Windows support just said something was wrong with my router, so it needs to be restarted. They were not very helpful.

I don't know what is the problem and how to solve this, since the router is working fine with other devices like my Android phone.

This is my ip config:

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::f8a3:5ac1:c2c4:c163%14
   IPv4 Address. . . . . . . . . . . : 192.168.0.100
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter isatap.{A02BC83E-DE76-44B9-AF93-FA1A2230320C}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   IPv6 Address. . . . . . . . . . . : 2001:0:9d38:6ab8:3c8e:111c:3f57:ff9b
   Link-local IPv6 Address . . . . . : fe80::3c8e:111c:3f57:ff9b%15
   Default Gateway . . . . . . . . . : ::

And one more thing, I have two VMware adapters which are disabled because I don't need it in Control Panel\Network and Internet\Network Connections:

VMware network adapter VMnet1 & VMnet8.

Please help me out. Thanks for your help.

Edit As requested, this is my ipconfig /all :

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Tama-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Atheros AR9485WB-EG Wireless Network Adap
ter
   Physical Address. . . . . . . . . : DC-85-DE-A4-E4-7D
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::f8a3:5ac1:c2c4:c163%14(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.100(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Monday, March 24, 2014 5:30:16 AM
   Lease Expires . . . . . . . . . . : Monday, March 24, 2014 9:30:16 AM
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 366773726
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-C7-9C-33-50-46-5D-3F-F5-09

   DNS Servers . . . . . . . . . . . : 8.8.8.8
                                       8.8.4.4
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 50-46-5D-3F-F5-09
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{A02BC83E-DE76-44B9-AF93-FA1A2230320C}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:83d:406:3f57:ff9b(Prefer
red)
   Link-local IPv6 Address . . . . . : fe80::83d:406:3f57:ff9b%15(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

And this is my screenshot from my router :

enter image description here

enter image description here

enter image description here

My adapters :

enter image description here

share|improve this question
    
pop into 192.168.0.1 your router interface and send us a screen shot. Also give us more detailed i.p. config info using "ipconfig /all" in cmd. I think there is a dhcp problem, with the lease time being short or something. May be there are two computers with the same name? who knows what is the cause, screen shot everything that is not a privacy issue and send it here. –  Pathfinder Mar 24 at 7:14
    
@Pathfinder done. Anything else you need? Yes, i just remembered the windows one time give me an error about my configuration and DHCP. So i restart the adapter, that error is gone, but not my problem. Thanks –  Blaze Tama Mar 24 at 8:23
1  
Why is Google providing the DNS? I suspect the issues are in your IP4 config page. Can you confirm if you're also using a static IP? –  Dave Mar 24 at 8:25
    
@DaveRook I obtain the IP address automatically and i use google's DNS because it think its faster than other –  Blaze Tama Mar 24 at 8:31
1  
I seriously think you should reset the lot - it just sounds like it's possibly your changes which have caused a conflict more than the router, and a quick reset will prove it (or not - just remember to take a back up of your router settings first :) ) –  Dave Mar 24 at 12:18

2 Answers 2

up vote 1 down vote accepted

Your settings seem fine, apart from the fact that you setup the dns on the wireless adapter and turned off the dns in the router. Privacy wise, a dns, if it wants to (and some do) it can log requests for i.p. of a server. Changing a dns does not affect download speed (youtube, google drive etc) only the establishment of connection which is normally .1 of a second. So why change? you only gain ~0.1 of a second connection speed. If you do, try to setup the dns on the router, not the adapter. It might change something. Also why is your gate way 192.168.0.1? it's on a different subnet.. change it back to 192.168.1.1

You specified wireless connection not "connecting" i.e. not authenticating. This can be due to the fact that some outside source is trying to crack your wifi router password... they can disconnect connections in attempt to gain packets of information. Post up the wireless settings page on the router, i suspect the card on the atheros to be conflicting with the router. i.e. b/g/n messing things up. 1st line of defence: firmware update. 2nd line of defence: sue the person using the 5Ghz transmitter for their remote control hobby =P (chances of your up to date set-up failing are very low, I personally am really surprised you are experiencing issues), I suspect interference.

While you are still reading this these are my proposed suggestions, I am studying networking at uni so I know what I am recommending =)

Research (thanks for your screenshots :) helps a BUNCH!): http://answers.microsoft.com/en-us/windows/forum/windows_8-networking/qualcomm-atheros-ar9485wb-eg-wireless-network/1c5a398d-2297-430c-b815-883fd492cb07?page=2 Give this a read, seems applicable to you.

  1. Reset the settings on the computer wireless adapter. also update it's drivers. link:http://www.atheros.cz/atheros-wireless-download.php?chipset=61&system=5
  2. Update the router by downloading the latest firmware corresponding to the hardware version: http://www.tp-link.com/lk/products/details/?model=TL-WR940N#down. Then logging into 192.168.0.1 and clicking on system tools -> firmware upgrade -> upload -> upgrade. Approx 10 min upgrade, don't unplug the power cable.
  3. Write down the wan settings on the router. Reset everything on the router: system tools -> factory defaults -> restore, to catch any trouble makers.
  4. Update the wireless settings and WAN settings, change SSID (hidden?), change WPA(2)-PSK password, manually select a channel, HIGH transmit power. 20mhz channel width (less range but your techy neighbours will thank you), restrict to b/g mode only, disable mac restrictions. half the beacon interval to 50 (makes it easier to find the router, but use more idle power).
  5. Change the router password. Hope you don't have a techy child that likes to change things, in which case you probably have to just live with it, gotta let them grow.

Good luck!

share|improve this answer
    
Thanks, thanks a lot for your help (its too bad i can only upvote once). I will try your suggestions this weekend, i will let you know what happened. –  Blaze Tama Mar 26 at 3:11
    
Sorry i forgot to accept your answer, Thanks :D –  Blaze Tama Apr 8 at 14:24
    
Welcome! Hope you, and future viewers have their problems solved because of what I write. –  Pathfinder Apr 8 at 15:25

I would suggest to find a firmware upgrade to your router, apply it and factory reset it, or if there is not update factory reset him.

If that wont help, try with your friend router - if problem is still there, check if you don't use external Wireless Configuration Application, disable it and try the build in windows application for Zero Configuration of Wireless.
Remamber that different machines/os/application do exact same things different ways ;-)

share|improve this answer
    
Thanks for your help, i will try your suggestion after everything else failed –  Blaze Tama Mar 24 at 8:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.