Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently installed Fedora 20 on my laptop. For the first thing, I tried to add Rpmfusion , Russianfedora to it; but it was failed. In the terminal I entered this:

su -c 'yum localinstall --nogpgcheck  http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'

and got this error:

File contains parsing errors: file://///etc/yum.repos.d/fedora-yum-fast-downloader.repo
    [line  5]:     name=A fast downloader plugin for yum

    [line  7]:     baseurl=http://repos.fedorapeople.org/repos/hedayat/yum-fast-downloader/fedora-20/noarch/

    [line  9]:     enabled=1

    [line 11]:     skip_if_unavailable=1

    [line 13]:     gpgcheck=1

    [line 15]:     gpgkey=http://hedayat.fedorapeople.org/gpg/hedayat-rpm-gpg-key

    [line 19]:     name=A fast downloader plugin for yum – Source

    [line 21]:     baseurl=http://repos.fedorapeople.org/repos/hedayat/yum-fast-downloader/fedora-20/SRPMS

    [line 23]:     enabled=0

    [line 25]:     skip_if_unavailable=1

    [line 27]:     gpgcheck=1

    [line 29]:     gpgkey=http://hedayat.fedorapeople.org/gpg/hedayat-rpm-gpg-key

Then I tried to add russianfedora repo using this command:

[root@dhcppc0 Daniel]# su -c 'yum install --nogpgcheck htttp://mirror.yandex.ru/fedora/russianfedora/russianfedora/free/fedora/russianfedora-free-release-stable.noarch.rpm htttp://mirror.yandex.ru/fedora/russianfedora/russianfedora/nonfree/fedora/russianfedora-nonfree-release-stable.noarch.rpm'

I got this error:

Loaded plugins: langpacks, refresh-packagekit


File contains parsing errors: file://///etc/yum.repos.d/fedora-yum-fast-downloader.repo
    [line  5]:     name=A fast downloader plugin for yum

    [line  7]:     baseurl=http://repos.fedorapeople.org/repos/hedayat/yum-fast-downloader/fedora-20/noarch/

    [line  9]:     enabled=1

    [line 11]:     skip_if_unavailable=1

    [line 13]:     gpgcheck=1

    [line 15]:     gpgkey=http://hedayat.fedorapeople.org/gpg/hedayat-rpm-gpg-key

    [line 19]:     name=A fast downloader plugin for yum – Source

    [line 21]:     baseurl=http://repos.fedorapeople.org/repos/hedayat/yum-fast-downloader/fedora-20/SRPMS

    [line 23]:     enabled=0

    [line 25]:     skip_if_unavailable=1

    [line 27]:     gpgcheck=1

    [line 29]:     gpgkey=http://hedayat.fedorapeople.org/gpg/hedayat-rpm-gpg-key

Why am I getting parsing errors in file://///etc/yum/repos.d/fedora-yum-fast-downloader.repo that prevent me from adding repositories?

See What included in fedora-yum-fast-downloader.repo

[fedora-yum-fast-downloader]

name=A fast downloader plugin for yum

baseurl=http://repos.fedorapeople.org/repos/hedayat/yum-fast-downloader/fedora-$releasever/noarch/

enabled=1

skip_if_unavailable=1

gpgcheck=1

gpgkey=http://hedayat.fedorapeople.org/gpg/hedayat-rpm-gpg-key

[fedora-yum-fast-downloader-source]

name=A fast downloader plugin for yum – Source

baseurl=http://repos.fedorapeople.org/repos/hedayat/yum-fast-downloader/fedora-$releasever/SRPMS

enabled=0

skip_if_unavailable=1

gpgcheck=1

gpgkey=http://hedayat.fedorapeople.org/gpg/hedayat-rpm-gpg-key
share|improve this question

3 Answers 3

up vote 2 down vote accepted

Thanks everybody for your helpful suggestions! when I got that by entering every command in Terminal the answer is a Parsing Error within the yum-fast-downloader.repo so I delete the file from the etc/yum.repos.d directory. then I got that by entering the same commands I got an error suggesting another parsing error in the skype repo file, so i delete it too. After all, I re-command for installing yum-fast-downloader.repo, then upgrade fedora repos. Now the problem is solved, and all the programs can be installed.

share|improve this answer

I am unable to determine from your error message the reason why the fedora-yum-fast-downloader repository file is failing to parse. However, I believe you can work around your error and successfully add your repositories as follows:

Whenever you invoke the yum command for any reason, include the following parameter:

--disablerepo=fedora-yum-fast-downloader

For example, to add the russianfedora repos, the command would be as follows:

yum install --nogpgcheck --disablerepo=fedora-yum-fast-downloader http://mirror.yandex.ru/fedora/russianfedora/russianfedora/free/fedora/russianfedora-free-release-stable.noarch.rpm http://mirror.yandex.ru/fedora/russianfedora/russianfedora/nonfree/fedora/russianfedora-nonfree-release-stable.noarch.rpm

This will temporarily make yum stop trying to parse the fedora-yum-fast-downloader repository, which should at least avoid the parsing error in the .repo file, allowing you to proceed. The workaround is imperfect, because the ideal case would be for you to look into that file /etc/yum.repos.d/fedora-yum-fast-downloader.repo with a text editor, and to figure out if there are some invalid characters that violate the .repo file format, and fix them.

If you think you can do that, you would be able to solve your problem "permanently" by doing so, and you would also be able to take advantage of the yum fast downloader plugin, which can improve the download speed of your yum in some circumstances (as the plugin's name suggests).

Edit: It looks like you also have three ts in your htttp URIs for the russianfedora repo. Make sure you change them to http, or you'll encounter yet more errors.

Edit 2: I think the newlines between each line in your fedora-yum-fast-downloader.repo file are causing the parse error. To check, please do the following:

  1. Rename the file /etc/yum.repos.d/fedora-yum-fast-downloader.repo to something else, or move it to another directory. You can mv it to your home directory to get it out of the way; that is my recommendation.
  2. Run wget -O /etc/yum.repos.d/fedora-yum-fast-downloader.repo http://repos.fedorapeople.org/repos/hedayat/yum-fast-downloader/fedora-yum-fast-downloader.repo as root.
  3. Try your repos again.

By fetching the repo file from the repo itself, you'll be able to eliminate the chance that your file is corrupted.

share|improve this answer
    
Thanks for your cooperation. I entered three t s in http urls because I didn't have enough reputations for asking my question. –  Daniel Mar 24 at 20:27
    
Now, I just opened the file fedora-fats-downloader.repo using gedit. you can see the text down to my question. –  Daniel Mar 24 at 20:33
    
@Daniel -- see my "Edit 2" comment. –  ÃŁŁǫǛȉЖΦΤїҪ Mar 25 at 13:13
    
thank you allquixotic, I did it, but the error was still on. by removing the yum-fast-downloader.repo and skype.repo my problem was solved. thank u again for your support. –  Daniel Mar 26 at 19:20
  1. open terminal and switch to root using su

  2. Download the rpmfusion repo definition file using wget http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-20.noarch.rpm and install it through yum localinstall --nogpgcheck ./rpmfusion-free-release-20.noarch.rpm

  3. Download the russianfedora repo definition file using wget http://mirror.yandex.ru/fedora/russianfedora/russianfedora/free/fedora/russianfedora-free-release-stable.noarch.rpm (you've got too much "t"s in the http in your russianfedora address) and install it through yum localinstall --nogpgcheck ./russianfedora-free-release-stable.noarch.rpm

After this magic you can use rpmfusion and russianfedora repos.

share|improve this answer
    
If you read his comment, he said he put three "t"s in the http URLs because he didn't have enough reputation for including links (an anti-spam feature of the site). Your answer is basically a re-hashing of the original question without providing any additional information. –  ÃŁŁǫǛȉЖΦΤїҪ Mar 25 at 13:14
    
@allquixotic I think that installing it all by localinstall would help. –  andrej Mar 25 at 18:32
    
thank u all so much because of your support. all what matters is the state of cooperation. –  Daniel Mar 26 at 19:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.