Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed flashplayer 10 for Firefox 3.5 and Internet Explorer 8 on Windows 7 x64. When I visit Test Adobe Shockwave & Flash Players page in IE8 I see a blank square where the flash animation should be. In FF for the same page, the animation shows. It's the same with Youtube, FF works and IE doesn't.

On other sites (1,2,3) neither browser works.

All of the links in this post work with 32bit IE7 on WindowsXP x64.

I've verified I'm using 32bit IE by starting it from "C:\Program Files (x86)\Internet Explorer". The IE menu "Tools > Internet Options > Programs > Manage add-ons" shows Shockwave Flash Object is enabled with a filedate and version of 17/07/2009 7:12pm v10.0.32.18.

  1. What are the next steps for troubleshooting?
  2. Any ideas why does FF only works sometimes?

thank you.

UPDATE: moving Firefox flash issues to a separate question as I don't think the issues are related.

UPDATE2: firefox was related after all. Complete solution turned out to be use the uninstallers from Adobe Labs, then install both 32bit and 64bit flash players for both IE and "all others" (so four installs in all). Thank you funkytown!

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

What I know is that sometimes when you upgrade flash player the old plugin is not removed. IE believes that you have the new version and will report that with JavaScript but the old version is still the one that gets loaded.

Here is a website where you can test

http://millionmind.com/ie8_faulty_flash_player_installation

share|improve this answer
    
this was it, thank you! the solution turned out to be: 1) uninstall flash player for all browsers (active-x for IE, flash player for FF), 2) install flash player for 64bit IE, 3) install flash player for 32bit IE, 4) install 32bit flash player for all other browsers (fixed firefox) -- using the (un)installes from Adobe Labs downloads –  matt wilkie Sep 21 '10 at 19:03
add comment

I've found this fix works for users with Firefox (32) installed on a 64-bit Windows 7 machine: http://thetechangel.com/blogberry/2010/01/firefox-flash-fix-for-windows-64-bit/

share|improve this answer
    
thanks for the link Daniel. I've asked for more details about the patch provided there (I'm reluctant to apply off-channel binary patches to a program which saves passwords :) –  matt wilkie Jan 26 '10 at 16:50
add comment

From some threads in the wild like this one, it appears this behaviour is not limited to 64bit machines, Vista or Win7. It is probably a security settings issue, and turning off IE8 Protected Mode (Tools > Internet Options > Security > [ ] Enable Protected Mode) allows flash to work, for me. Not sure what the ramifications are for this, probably not good so it's definately only an interim measure.

On the thread mentioned David Spector says

... it's a security bug. One can argue whether it is Microsoft's fault or Adobe's fault,... Microsoft changed the way that certain packages are signed with security certificates. Adobe didn't get the word, and continued to sign their releases in the same old way. The result is that current Internet Explorer browsers, versions 7 and 8, report an error for any website running Flash, and refuse to download the latest version.

David goes on to conclude the changing security settings don't work, but that is not true in my case at least (perhaps he changed security level but not proteced mode?).

The problems reported with Firefox is an unrelated profile or extension issue. Portable Firefox on the same machine has no problems with flash.

share|improve this answer
add comment

if you're running a firewall, check if he's not blocking any active contents (eg Flash).

There is a "DEBUG version" fo flash you can get from the adobe site, but that's a developper tool to ckeck for flash problems/behavior.

as a last ressort, reset the IE8 advanced settings (under internet options/advanced settings).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.