Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Redhat Linux 6.5 with Gnome 2.28.2 desktop.

I'm trying to create a shortcut to open a terminal by pressing just the super key (i.e. the windows key or mod4) not a combination of the super key and some other key. The gnome-keybinding-properties gui will not let me enter just a modifier key (it wants something like super+d).

How can I tie this shortcut to just the super key?

I've tried editing .gconf/apps/metacity/global_keybindings/%gconf.xml with no luck. I did this in my previous version of gnome (2.16.0) and also with an ubuntu 13.04 install. But I can't figure out how to do it here.

Thanks

share|improve this question

1 Answer 1

I dug through an old computer that had this setting enabled and was able to manually update the config file that made this work (couldn't do it through any gui I found).

The file:

/home/(username)/.gconf/apps/metacity/global_keybindings/%gconf.xml

The contents:

<?xml version="1.0"?>
<gconf>
    <entry name="run_command_terminal" mtime="1395776965" type="string">
        <stringvalue>Super_L</stringvalue>
</entry>
</gconf>

The key for me using "Super_L" as the string value. When edited with the gui it was using "Mod4"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.