Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This problem is driving me nuts. My iPhone Remote app longer can control the iTunes instance on my Vista desktop machine. It used to work several months ago and I haven't been able to get it working since.

When I attempt to reset it (by removing and select "Add Library"), iTunes does not see my iPhone as a device.

I would assume it's something with my wireless network, but here's the kicker: if I start iTunes on my Macbook, the iPhone will show. (And yes, I've made sure to try it on the desktop when the Macbook is off.)

I've tried removing the Remote app & re-installing. No luck.

I've tried toggling the "Look for iPhones & iTouch remotes", as well as "Forget all remotes." No luck in either case.

I'm running iTunes 9.0.2.25 & iPhone Remote 1.3.3 (4).

Any suggestions for how to proceed? Can I try pinging a port or possibly something I could try to packet sniff from the desktop?

Any help is great appreciated.

share|improve this question

2 Answers 2

Do you have windows firewall turned on? If so, try turning it off, and seeing if that has any effect... If it does, you will need to make any firewall exception for iTunes...

share|improve this answer
    
No, it's turned off all together. –  Bill Reardon Nov 21 '09 at 20:29
    
Have you changed, or upgraded your antivirus? Some antivirus packages include their own firewalls... Apple has the Apple Remote troubleshooting page here: support.apple.com/kb/TS1741 –  Benjamin Schollnick Nov 21 '09 at 22:00
    
Thanks, I'll check out the support page. I wasn't able to find that despite a lot of time searching. :) –  Bill Reardon Nov 28 '09 at 18:57
up vote 0 down vote accepted

The fix was enabling "Network Discovery" in Vista.

This must have come along in one of the service patches, which made it stop working. I restrict access to my wireless network via MAC address, so Vista thought it was an "open network" and disabled this option.

After enabling & restarting iTunes, iPhone Remote & iTunes were able to find each other again!

Thanks to Benjamin for the pointer in the right direction!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.