Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to connect Subversion client on a Red Hat machine to a Windows Server 2012 machine with VisualSVN Server running. My goal is to run an svn export via a shell script on the linux machine to retrieve code for the development server.

First I tried to connect using the default https Repo connection string..

svn export --username user --password pass https://OPSSVN1/svn/volunteers/ ./svn-export

the linux box returns...

svn: Server sent unexpected return value (501 Not Implemented) in response to OPTIONS request for 'https://OPSSVN1/volunteers'

So I went and installed svnserve.exe as a service listening on to 3960 and changed the script to..

svn export --username user --password pass svn://OPSSVN1:3960/volunteers/ ./svn-export

I get the following message

svn: Can't connect to host 'OPSSVN1': Connection refused

Now if I use either connection string from a window's desktop it works fine.

Other facts known that might help...

  • The Windows server has the firewall opened up for the port.
  • The linux box can ping the machine
  • the linux box can Telnet into port 443 on the windows box
  • The linux box cannot telnet into port 3960 on the windows box
  • Linux SVN version: svn, version 1.6.11 (r934486)
  • VisualSVN Version 2.7.2

The SVN service I setup on windows was done with the following command.

cmd /c sc create subversion binpath="c:\svnserve\svnserve.exe --service -r E:\Repositories --listen-port 3960"

With the folder svnserve being a symbolic link to the visualsvn bin folder thats in the program files x86 directory.

Any ideas on how I can get this linux box to export the code from VisualSVN?

share|improve this question
    
Found this is probably going to be a linux issue. THe server I tried this from didn't like it. Another server that is similar it worked fine. They have the same version installed. I welcome any thoughts. –  Isisagate Mar 27 at 20:45

1 Answer 1

  1. It looks like that you enter invalid URL.

    Where did you get the URL https://OPSSVN1/volunteers/? URLs of VisualSVN Server repositories usually look like https://<hostname>/svn/<repository-name>. In your case the URL has to be https://OPSSVN1/svn/volunteers/ unless you hide VisualSVN Server behind a reverse-proxy.

  2. You are using too outdated Subversion 1.6.11 client on Linux machine.

    Subversion 1.6 is no longer supported starting with 1.8 release. The particular 1.6.11 version was released on 19 Apr 2010 and is too outdated. It's behind 11 patch releases, in fact. The latest Subversion 1.6.23 client was released on 30 May 2013 and includes a lot of fixes. If you must use svn 1.6 client, at least update it to the latest patch release then.

    On the other hand, you have to consider upgrading your clients to the latest Subversion 1.8 release.

share|improve this answer
    
1. The OPSSVN1/volunteers url was because that is was was needed to make the svnserve service that is listening to port 3960 find the files. The Typical url visual svn provides didn't work when using svn://, you are right in that the /svn/ is what the first attemp t actually had in it, I copied the second attempt and modified it for the post, So I will edit it. –  Isisagate Mar 28 at 12:50
    
2. What is odd is on one linux server both with the exact same svn installed it gives me a connection refused and the other works. –  Isisagate Mar 28 at 12:51
    
@isisgate, VisualSVN Server does not support using svnserve. Don't mix the troubleshooting, because you have to investigate the original issue when using HTTP(S). svnserve is another story and using it won't help to troubleshoot this behavior I'd say. –  bahrep Mar 28 at 12:52
    
Do you think updating the svn on the linux box will make the https version work ok? –  Isisagate Mar 28 at 12:55
    
@Isisgate it may, but I can't say for sure. Try the latest svn 1.6.23, 1.7.16 and 1.8.8: subversion.apache.org/packages.html –  bahrep Mar 28 at 12:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.