Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Vista Prof 32bit on a lenovo w500 thinkpad. I have four external drives and use 4 different PCs, that all have system volume information folders, taking up lots of space, and I can't delete them.

I don't even know which computer's files are backed up on which external.

I've used Thinkvantage rescue and recovery to delete all backups, as well as checked system restore settings to only use my main C drive. I checked all the PC's to ensure only the Main drive keeps system restore points and deleted previous versions. I ran Disc Clean up too.

But I can't figure out how to get rid of these large folders from my external drives.

share|improve this question

6 Answers 6

The solution is take ownership of the directory "System Volume Information":

Assuming the external drive is named G, Start cmd.exe using "Run as administrator" and type:

G:
cd \
takeown /r /f "System Volume Information"

Answer "y" for yes when asked if to replace all permissions.

This will replace the existing owner SYSTEM by yourself, so you can delete the directory.

EDIT

In Windows 7 & Vista you'll need to check that you're the real administrator:
Unhiding the "real" Administrator account

share|improve this answer
    
comment from Nadude: @harrymc I just upgraded to win7, and i tried your method, but got the following error. "ERROR: File ownership cannot be applied on insecure file systems; there is no support for ACLs" –  quack quixote May 8 '10 at 14:37
    
@Nadude: See my edit. Does that help? –  harrymc May 8 '10 at 17:43

Boot to the recovery console or a Linux Live CD and delete them. Windows makes it very difficult to delete them while it's running. Before you do it though make sure they won't show up again when you restart windows.

Go to Control Panel -> System -> System Protection. Make sure that it is off on the external drives.

share|improve this answer
    
comment from Nadude: @Marcin I dont know how to boot to recovery console/live cd. –  quack quixote May 8 '10 at 14:38

Use

RMDIR /s /q

This is for removing a directory in Windows 7. It's the same as DELTREE in DOS.

share|improve this answer

Plug your external drive into any Mac running OS X or any computer running a Linux distro (e.g., Ubuntu). Find the 'System Volume Information' folder. Drag it to the Trash. Eject the drive. Done!

share|improve this answer

I'm on Windows 7 trying to delete the restore points in System Volume Information in an external drive with FAT32. I tried takeown and it returned "ERROR: File ownership cannot be applied on insecure file systems". So I right clicked the drive, chose Properties, Sharing, Advanced Sharing, Share this folder, Permissions, Add, my username on Windows 7, Full Control. Then I went Computer, Network, "System Volume Information" appeared there, I clicked on it and from there I was able to delete the restore points manually.

share|improve this answer

The Solution I found to work - after trying innumerable numbers of commands- was this (from the linked Forum):

there's a simple way to do so : (the quotation marks are NOT needed, except if specified before)

considering you have Total Control on the folder "System Volume Information" :

Step 1 : click on "Start" type "run" and press Enter (or step 1 :Win+R)

step 2 : in the command prompt window called "Run" type "cmd" and press Enter

Step 3 : type the drive letter and a semicolon and press Enter (eg: "I:" and press enter)

Step 4 : the quotation marks are needed for this step type : rmdir "System Volume information" /S /Q Press Enter

Done

Sevenforums.com

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.