Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

after hours of trying various things I'm officially stumped. I can communicate with my raspberry pi via direct ethernet connection (without router or switch) from my windows box but not my linux box! What the heck is going on? Your expertise is needed in this dire situation.

I'm running the NOOBS debian on my pi. I'm trying to ssh in from Ubuntu 12.04 linux.

  • I tried using both Ubuntu's networkmanager and also removing it from nm and just using ifconfig to set manual IP address - 192.168.1.2 for pi, 192.168.1.4 for ubuntu. 192.168.1.4 worked for windows box.
  • I tried editing /etc/network/interfaces on ubuntu box after removing eth0 from networkmanager, rebooting etc.
  • I ran dhclient eth0 -r to revoke the dhcp lease before adding my static ip.
  • Tried both crossover and normal ethernet cables - either work with windows.
  • Tried disabling my wireless adapter (on dhcp, 192.168.2.X network), wireless works concurrently on windows.

Output of ifconfig

eth0      Link encap:Ethernet  HWaddr 20:89:84:37:df:19 
      inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:0 (0.0 B)  TX bytes:358 (358.0 B)
      Interrupt:16

lo        Link encap:Local Loopback 
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:1944 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1944 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:174046 (174.0 KB)  TX bytes:174046 (174.0 KB)

wlan0     Link encap:Ethernet  HWaddr 9c:4e:36:9e:c3:e0 
      inet addr:192.168.2.18  Bcast:192.168.2.255  Mask:255.255.255.0
      inet6 addr: fe80::9e4e:36ff:fe9e:c3e0/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:31930 errors:0 dropped:0 overruns:0 frame:0
      TX packets:1332 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:5849099 (5.8 MB)  TX bytes:130638 (130.6 KB)

Output of ip route show

default via 192.168.2.1 dev wlan0  proto static
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.4
192.168.2.0/24 dev wlan0  proto kernel  scope link  src 192.168.2.18  metric 9 

I'm unable to so much as ping the raspberry pi from Ubuntu. Trying to fix this so I can ssh into it. Any and all help is appreciated. Thanks in advance!

share|improve this question

migrated from stackoverflow.com Mar 28 at 9:07

This question came from our site for professional and enthusiast programmers.

    
ifconfig and route are deprecated, stop using them. Use ip addr and ip route instead. –  BatchyX Mar 28 at 21:06

1 Answer 1

up vote 0 down vote accepted

Looks like it was an issue with my wired ethernet driver detecting the hardware but not being able to use it properly. Not a networking issue after all. Long story short: make sure your hardware is working properly before getting hung up in configurations.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.