Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since the iTunes 9.0.2.25 update (or thereabouts) on Windows 7 (32-bit) build 7100 I get the following message every time I start iTunes:

iTunes

iTunes.exe has been set to run in compatibility mode for an older version of Windows. For best results, turn off compatibility mode for iTunes before you open it.

I have checked C:\Program Files\iTunes\iTunes.exe and compatibility mode is disabled, and I get the message even if I run it directly from there.

How do I get rid of the message?

share|improve this question
    
This is definitely not an answer, but if you wait a few months, this problem will be solved "naturally"... –  Yar Dec 24 '09 at 14:38
add comment

2 Answers

up vote 2 down vote accepted

FOUND THE ANSWER and works 100% ! Windows 7 64 bit

You can read about it here: http://discussions.apple.com/message.jspa?messageID=10397771#10397771

Or if you don't want to open that and take a look just do this:

Locate: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

in your regedit

and delete the itunes.exe entry.!

share|improve this answer
add comment

You said the compatibility mode is turned off for the .exe itself, but is it turned off for the shortcut you're using to open iTunes? Right-click the shortcut and go to Properties to check.

share|improve this answer
    
Sorry I didn't specifically say I'd checked that in the question, but I have. Running the .exe directly would avoid it anyway. :) –  GraemeF Dec 25 '09 at 13:42
add comment

protected by Diago Nov 24 '10 at 19:29

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.