Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Issue

Trying to host a network to extend the range of my home wifi network, instead of going out and spending 50 bucks on a wifi extender.

Anyways my issue occurs in that my hostednetwork does not have internet access no matter what I've tried.

What I've done

Setting up

First things first, I started by starting up ICS first, as I need the DHCP server to assign IP's in the range of 192.168.137.x on my to be hostednetwork.

I then set up a hostednetwork via command line like so:

netsh wlan set hostednetwork ssid="Test" key="password"
netsh wlan start hostednetwork

It works fine, I was able to test this connection by syncing my phones music collection 'over wifi' (DoubleTwist AirSync). I state this because I had originally started my hostednetwork first, which starts ICS in standalone mode, which then assigns IP's in 192.168.173.x instead, and DoubleTwist could not find my phone. Though I could've just released and renewed IP's once I had the ICS full mode started.

Anyways next step I took. I went into to network adapter settings, right clicked my wifi adapter that's connected to my home network and enabled shared internet connection with the newly created hostednetwork.

Nada, nothing happens.

System Information

IPconfig /all

Network Adapter Settings


I have no idea why this isn't working, every guide and support forum I've googled have done exactly what I have and it's worked for them. I'm guessing it's because I'm trying to share internet from the same adapter as I am broadcasting from. I would love to be able to broadcast from a seperate dongle (I have a spare) but windows doesn't support that natively.

share|improve this question

2 Answers 2

You need to share the internet connection that you are using on your computer. You need to go to Network Center and then to Adapter Settings. Then right-click the connection you want to share, then click properties and go to the share tab. There you need to share with your hostednetwork.

share|improve this answer
Which is what I have done. –  Eric Mar 29 at 20:50
Scratch that apparently it has been working. Windows says there's internet connectivity on it. My phone just doesn't think there is. –  Eric Mar 29 at 21:28
I'm sorry I read it too fast. It's a whole other problem if your phone doens't see the connection. What kind of phone do you have? If have encountered some problems as well. My phone can't connect to my network. –  user3460553 Mar 30 at 8:51

maybe a little late for you and maybe you've already bought a wifi extender or something. However I'm extending my wifi signal just the way you were trying and didn't succeed at first but then i used the command line without the "" marks, and now everything is working just fine. I've tried some more things which might possibly influence the process, but i can't exactly remember them.

share|improve this answer
I gave up on it actually. It was all working fine actually, just for whatever reason my Nexus 4 doesn't like using the shared internet. But I do know internet was being shared correctly, I was able to connect to it via a laptop. –  Eric May 7 at 19:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.