Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I run on a standard Charter Internet, 30 MBPS. Anytime I download something though, via steam or battle.net my internet completely drops out and only focuses on the download - which is only 1.1MB/s at a time.

I have a Netgear N300 Wirless Router and anytime I run my internet through that, my download speeds drop to 12MBPS. What do I need to do so I can get the same speeds through my Netgear Wireless as I do my Charter Router?

Also, I'm talking about getting 12MBPS through the wire, not wirelessly.

share|improve this question
    
Don't those services use bittorrent or similar techniques. You would have to use some tool to monitor the traffic and connections to see what happens on your side of the network but it may well be some limitation technique on the ISP side. –  Pavel Šimerda Mar 30 at 18:04
    
Well if I plug it directly into the Charter router I receive correct speeds which is why I believe it has something to do with the netgear router. –  Howdy_McGee Mar 30 at 18:22
    
1. Call charter make sure everything is running fine on their end. 2. Buy a new router and see if the problem continues. –  Sickest Mar 30 at 18:25
    
Talked to charter - everything was fine on all tests. Is spending 50+ on a new router really the solution here? –  Howdy_McGee Mar 30 at 18:26
    
it would be the fastest solution to isolate the problem, also no one said you have to keep the new router. Otherwise i would say call netgear and ask them why it's happening. –  Sickest Mar 30 at 18:43

1 Answer 1

Turns out my Router was telling me I had the most up-to-date firmware, but in order to use that updated frimware I needed to reset my router to factory settings. Once I did this I started to get the correct speeds.

share|improve this answer
    
Hmm, so it was a software problem. –  Pavel Šimerda Mar 30 at 21:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.